PaulsCode Forum

Mupen64Plus AE => Support => Topic started by: koekje on December 18, 2011, 11:49:20 AM

Title: Unable to map Z trigger to camera button
Post by: koekje on December 18, 2011, 11:49:20 AM
wow paul getting ready for the market! I still remember you saying woohoo i can see mario! :p anyway with the latest version i wanted to put my camera button as Z button but it would work :/
Title: Re: Unable to map Z trigger to camera button
Post by: Paul on December 18, 2011, 06:11:59 PM
I am going to put together a verbose test for you to run, but unfortunately I'm having trouble figuring out how to change the Android unique package name without also changing the Java package name.  I'm posting some questions around on various forums to see how to do it (this is an important capability for future testing without requiring users to uninstall the official build every time).  It may be a couple days before I get around to writing the test (we are driving to Kansas to visit family for the holidays tomorrow, so I won't be able to do any development until we get there - its about a 20 hour drive).
Title: Re: Unable to map Z trigger to camera button
Post by: Paul on December 18, 2011, 08:50:21 PM
Hah!  I got an answer to my question.. I'll post a test for you shortly.
Title: Re: Unable to map Z trigger to camera button
Post by: Paul on December 18, 2011, 09:26:22 PM
Ok, please run the following test.  It will install a second app called "Mupen64 Plus TEST", so make sure you run that one not the official build.  First go into the input settings configure menu, and select the Z button to bring up the key listener dialog.  Then press the camera button several times.  Then go back to the main menu and start a game.  Once the game has loaded, press the camera button several times again.  Then shut down the app and grab the logcat output.

Keymapping Test (http://www.paulscode.com/source/Mupen64Plus-AE/18DEC2011/Mupen64Plus-debug-keymaps.apk)
Title: Re: Unable to map Z trigger to camera button
Post by: Paul on January 05, 2012, 08:26:16 PM
Just checking if you've had a chance to run that test, or if you are still having the problem.  I've been pretty busy with other support questions, so I don't want to forget about this one.
Title: Re: Unable to map Z trigger to camera button
Post by: Paul on January 29, 2012, 05:53:14 PM
I've figured out what is causing this.  Apparently, the hard-press of the camera button causes apps to return to the home screen (presumably to open the Camera app for taking pictures).  I'm not sure how to get around this problem at the moment, but I'll continue searching.