PaulsCode Forum

Mupen64Plus AE => Support => Topic started by: Dr_Bunsen on March 17, 2016, 05:06:29 PM

Title: Games don't show up in latest alpha builds
Post by: Dr_Bunsen on March 17, 2016, 05:06:29 PM
On NVidia Shield Portable running Lollipop, after scanning for games, nothing shows up in the games list on the last couple of the Alpha builds. Had to go back a few revs to get one that would.
Title: Re: Games don't show up in latest alpha builds
Post by: fzurita on March 17, 2016, 06:25:50 PM
Which was the last revision that showed games? Nothing has changed in ages that should be affecting the scanning of games.
Title: Re: Games don't show up in latest alpha builds
Post by: fzurita on March 17, 2016, 07:31:00 PM
On NVidia Shield Portable running Lollipop, after scanning for games, nothing shows up in the games list on the last couple of the Alpha builds. Had to go back a few revs to get one that would.

Try the latest. Let me know how it goes.
Title: Re: Games don't show up in latest alpha builds
Post by: Dr_Bunsen on March 18, 2016, 09:30:06 AM
Will try the latest, thanks. I thought it might be an SD card permissions issue since I had that problem on my Shield Android TV when it went to Marshmallow, but Lollipop doesn't seem to have the same permit/deny permissions control (which is what I used to fix the issue on the SATV) so I don't think it's that.
Title: Re: Games don't show up in latest alpha builds
Post by: Ookler on March 21, 2016, 10:47:13 AM
I'm having the same issue on my NVIDIA SHIELD Android TV device (latest build I tested was Mupen64PlusAE_master_201603210002_2a0383d).  The last build showing games for me was the 03/15/2016 build.  I tried all the newer ones since then and they scan the folders quickly showing the names of the games during the scan (they are in .n64 format), but when the scanning finishes, no games appear on the screen.

Now whenever going back to the 03/15/2016 build (I tried a few earlier ones as well), I cannot get the games to show up at all.  Very odd.  I tried removing the app, deleting all related folders/settings, resetting everything related to Mupen64Plus AE that I could think of, but I cannot get any games to appear.

I love the emulator and would like to thank everyone involved.  Any ideas how to fix this issue?
Title: Re: Games don't show up in latest alpha builds
Post by: retroben on March 21, 2016, 11:52:40 AM
The storage permission is wrongfully disabled.
App options,storage,enable storage permission on Mupen64Plus AE entry,done. :)
Title: Re: Games don't show up in latest alpha builds
Post by: fzurita on March 21, 2016, 12:39:18 PM
This is interesting. If the permission is disabled, it should ask for the permission. The change from 3/15 was to add the Manifest.permission.READ_EXTERNAL_STORAGE permission. Maybe I messed something up.

I added that permission back because the shield portable was having problems scanning for games. But now that I added it back the Shield TV now has problems....
Title: Re: Games don't show up in latest alpha builds
Post by: Ookler on March 21, 2016, 01:22:03 PM
The storage permission is wrongfully disabled.
App options,storage,enable storage permission on Mupen64Plus AE entry,done. :)

Thanks for your reply.  Sorry for the noob question, but is that permission setting something I can adjust on my NVIDIA SHIELD Android TV device, or is that something in the programming of the app you are referring to?  I looked around under the SHIELD's settings and found a permission screen for Mupen64Plus AE, but it just lists the permissions it has--no option to enable/disable anything.
Title: Re: Games don't show up in latest alpha builds
Post by: retroben on March 21, 2016, 02:43:39 PM
Go into settings and to the apps from there then go down to see the single square named app options where a list of permissions and apps using them are located.

Unless you are on Lollipop from blocking updates somehow.
Title: Re: Games don't show up in latest alpha builds
Post by: Dr_Bunsen on March 21, 2016, 03:07:30 PM
FYI I'm using the last auto build master of 2015 and not having any problem with the list now on my Shield Portable. Also the frame rate is about 30 to 40% higher on Goldeneye (my reference for having difficulty at running with decent frame rates) with the older build than recent ones  with little or no sound breakup compared to later builds using the same video and sound emulation.
Title: Re: Games don't show up in latest alpha builds
Post by: Ookler on March 21, 2016, 04:54:56 PM
Go into settings and to the apps from there then go down to see the single square named app options where a list of permissions and apps using them are located.

Unless you are on Lollipop from blocking updates somehow.

Thanks for the reply.  I was on Lollipop (I've been too lazy to update because I'd have to reroot).  So yeah, I just upgraded to Marshmallow and now I see the permissions icon under settings -> apps.  It was disabled for Mupen64Plus AE, so I enabled it, but it's still not showing any games after scanning the proper directories.  I tried the latest .apk release from today as well as the one from 03/15/2016 that had worked for me earlier... not sure what the deal is.

After removing the app to install an older version, what are the leftover directories that need to be manually deleted so it looks it was never installed?  I'm just wondering if somehow installing multiple versions mixed up some kind of settings that's not allowing the games to be displayed for some odd reason.
Title: Re: Games don't show up in latest alpha builds
Post by: fzurita on March 21, 2016, 05:11:00 PM
Can you share your logcat? I just ran a scan with my shield TV and it worked fine. The logcat can be found under the help menu.
Title: Re: Games don't show up in latest alpha builds
Post by: Ookler on March 21, 2016, 05:23:25 PM
I couldn't get it to save to a file, so here are some screenshots:

http://s24.postimg.org/9eetwa7hx/Mupen_log_1.png
http://s24.postimg.org/yyh42psvp/Mupen_log_2.png
http://s24.postimg.org/5grk6vkol/Mupen_log_3.png

EDIT: While running Mupen64Plus AE, I just went to Settings -> Data -> Reload app resources then rescanned and boom... the games were all there.  I could've sworn I had already tried this when still on Lollipop and it didn't work, but it's working now.
Title: Re: Games don't show up in latest alpha builds
Post by: fzurita on March 21, 2016, 06:55:42 PM
Great, you managed to pick a good section of the logcat. Go to settings on the gallery sidebar, then go to data. From there, make sure that you have selected a proper "Game save folder".

Usually /storage/emulated/0/mupen64plusae-v3-alpha