PaulsCode Forum

Mupen64Plus AE => General Discussion => Topic started by: littleguy on April 12, 2013, 08:20:04 PM

Title: Junk graphics on the side of mario, with rice
Post by: littleguy on April 12, 2013, 08:20:04 PM
Ok, I think I'm going insane.  After the bridge merge I noticed that on my Xperia Play, rice is giving junk graphics on the sides where the black pillarboxes should be - in Mario 64 no less.  Naturally I panicked... So I started going back, back, back to 2.1.0.  Complete reinstall, complete clean build.  Problem is still there.  I'm going to keep going back in time...

Did I miss something or did rice always do this on the Xperia Play?  I could have sworn I never had this problem before.
Title: Re: Junk graphics on the side of mario, with rice
Post by: Paul on April 12, 2013, 08:49:25 PM
It doesn't do this on my Galaxy Nexus or the OUYA, but it has been reported on several other devices (ever since Stretch Screen could be disabled).
Title: Re: Junk graphics on the side of mario, with rice
Post by: littleguy on April 12, 2013, 09:35:03 PM
Hmm yeah I've seen the problem before, I just don't recall seeing it for mario with rice on the xperia Play.  Any other xperia play users out there that can confirm this is an issue?
Title: Re: Junk graphics on the side of mario, with rice
Post by: Infinite Jest on May 10, 2013, 10:29:55 PM
I don't have an Xperia play, but experience this with rice on my DNA.

https://www.dropbox.com/s/zn3s8i14g62jxo1/2013-04-05%2002.08.18.png
Title: Re: Junk graphics on the side of mario, with rice
Post by: scorpio16v on May 21, 2013, 11:19:24 AM
On Pilot Wings, the messed graphics didn't only affect the border, even the main screen is messed up.

https://dl.dropboxusercontent.com/u/17774073/pilotwings.png

That picture is from Playstore version on Nexus 4.

On my Onda v812, the bug looks different.

https://dl.dropboxusercontent.com/u/17774073/pilotwingsononda.png
Title: Re: Junk graphics on the side of mario, with rice
Post by: Mikhail on May 23, 2013, 02:59:01 AM
I'm also getting garbled and missing textures in F-1 World Grand Prix II

Hub graphics garbled as normal with plugin but mupen64ae adds in a few more glitches.

Cockpit view - wheels & nose cone not rendered,
Overhead fullcar view - Full car is completely missing in this view.
T-Cam view - wheels, monocoque chassis and nose cone not rendered.
Title: Re: Junk graphics on the side of mario, with rice
Post by: Mikhail on May 23, 2013, 03:37:48 AM
Another F1 game this time called F1 Racing Championship

The steering wheel and wheels are rendered in the wrong positions,  wheels should appear higher up and the steering wheel lower down.
Title: Re: Junk graphics on the side of mario, with rice
Post by: Mikhail on May 30, 2013, 11:20:13 AM
Updated above posts with real mupen64ae vs n64oid examples instead of project64 example edits, sorry for noobness but I only recently discoved how to take screenshots on android.
Title: Re: Junk graphics on the side of mario, with rice
Post by: Mikhail on May 30, 2013, 11:30:42 AM
t-cam
Title: Re: Junk graphics on the side of mario, with rice
Post by: Paul on May 30, 2013, 02:37:01 PM
We're getting a little off-topic here, but thanks for the screen-shots.  How does gles2glide64 fare with that game?
Title: Re: Junk graphics on the side of mario, with rice
Post by: Mikhail on May 30, 2013, 06:51:39 PM
No graphic problems with glide on f1wgp2 just runs slow with control lag, frameskip makes the lag worse so you end up basing all the walls at monaco, runs alot smoother on n64oid but there's still slight noticable lag.

F1 RC with glide has flickering on the expansion pak checking text as well the course, driver selection screens but the steering wheel & wheels textures are displayed in the correct position like n64oid.
Title: Re: Junk graphics on the side of mario, with rice
Post by: littleguy on May 30, 2013, 07:08:48 PM
There is currently no frameskip option for the gles2glide plugin... Not sure what you're referring to.