Author Topic: Most games have a choppy feel. Likely caused by audio.  (Read 6638 times)

Offline Vexrak

  • byte
  • *
  • Posts: 16
    • View Profile
Re: Most games lagging due to the default audio plug-in.
« Reply #15 on: September 23, 2016, 11:35:32 PM »
It hasn't made a difference. :c
I really appreciate you helping!

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 558
    • View Profile
Re: Most games lagging due to the default audio plug-in.
« Reply #16 on: September 23, 2016, 11:50:19 PM »
What games are being choppy right now?

Offline Vexrak

  • byte
  • *
  • Posts: 16
    • View Profile
Re: Most games lagging due to the default audio plug-in.
« Reply #17 on: September 23, 2016, 11:53:42 PM »
Mainly OoT, Majora's Mask, and Star Fox 64.
I guess all of them though.
« Last Edit: September 23, 2016, 11:57:06 PM by Vexrak »

Offline Vexrak

  • byte
  • *
  • Posts: 16
    • View Profile
Re: Most games lagging due to the default audio plug-in.
« Reply #18 on: September 24, 2016, 12:11:25 AM »
This problem could all be fixed by a setting to change your frame rate cap without changing the speed.  ::)

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 558
    • View Profile
Re: Most games lagging due to the default audio plug-in.
« Reply #19 on: September 24, 2016, 12:27:42 AM »
The thing is that changing the frame rate cap changes the speed.

Are games like going up and down in frame rate? It really sounds like you are still using the Glide64 Fast emulation profile which has frame skip enabled.

I would try all the different emulation profiles, especially Glide64 Accurate and all the GLideN64 ones.

Offline Vexrak

  • byte
  • *
  • Posts: 16
    • View Profile
Re: Most games lagging due to the default audio plug-in.
« Reply #20 on: September 24, 2016, 01:10:38 AM »
So, the games are all around max FPS, but it has that laggy feel.
I've tried every emulation profile, and GlideN64-GLES 3.1 works best.

I guess the problem keeps changing as we go, sorry for all the hassle but I'm really appreciative of you helping.

So the new problem = Getting rid of laggy/choppy feel.

Offline Vexrak

  • byte
  • *
  • Posts: 16
    • View Profile
Re: Most games lagging due to the default audio plug-in.
« Reply #21 on: September 24, 2016, 01:20:34 AM »
Though I guess that's what all N64s have, emulator or original.

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 558
    • View Profile
Re: Most games lagging due to the default audio plug-in.
« Reply #22 on: September 24, 2016, 08:24:37 AM »
So if you find footage of a real n64 in YouTube, does it also have that laggy/choppy feel to it? I'm still not ruling out a problem with the app.

Also, try a game with a higher FPS like super smash brothers and F-zero. Do those feel less choppy and laggy?
« Last Edit: September 24, 2016, 07:19:46 PM by fzurita »

Offline Vexrak

  • byte
  • *
  • Posts: 16
    • View Profile
Re: Most games lagging due to the default audio plug-in.
« Reply #23 on: September 24, 2016, 06:00:46 PM »
Well, the videos don't have the choppiness... I can't really say for the lag though, there's barely a difference.
Oh, pardon, I've never really described what the "choppiness" is, it's just one part of the game stopping for a while, either the audio, graphics, or controls.

Other than that, there doesn't seem to be any problems.

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 558
    • View Profile
Re: Most games have a choppy feel. Likely caused by audio.
« Reply #24 on: September 24, 2016, 07:23:03 PM »
Gotcha, I wonder if your phone is letting other processes take priority momentarily.

Nato

  • Guest
Re: Most games have a choppy feel. Likely caused by audio.
« Reply #25 on: December 28, 2016, 11:25:12 AM »
Hey, you probably already know this, but if anyone else is having choppy video lag try:

1. Select your game from the menu, and in the settings change the Rendered Resolution from Native Resolution to 800x600.

2. During gameplay, bring up the Mupen64plus menu and select Desync audio.

3. In the Audio plugin menu, select SLES 2.0 and enable Time Stretch Audio, set Audio Buffer Size to 256, set Audio Buffer Number to 10, set Sampling Rate to Set by Game.

4. Set your Emulator profile to Glide64 Fast.