Author Topic: Problem with zipped roms?  (Read 4280 times)

Offline MusicNomad

  • bit
  • Posts: 5
    • View Profile
Problem with zipped roms?
« on: December 21, 2011, 07:28:32 PM »
I bumped into something that's puzzled me.  I have a zipped rom of Mario Cart that put me back to the menu screen when I tried opening it but opens perfectly fine when unzipped. I've opened other zipped roms before but it's weird because some will open, some will close to the menu screen.

Anyone else experience this? It's not a huge deal but sort of unusual
Device: Xperia Play 4g
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.3
App Version: xperia play beta v1. 1

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Problem with zipped roms?
« Reply #1 on: December 21, 2011, 07:39:24 PM »
Im not sure if zip support is fully functional yet. What format is your zip file? zip, 7z, rar?

I got a super mario 64 zipped rom to run but I havent tested any other games.
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Problem with zipped roms?
« Reply #2 on: December 21, 2011, 07:41:47 PM »
all of my zipped roms seem to run fine but they all have only one rom per zip file.

Offline MusicNomad

  • bit
  • Posts: 5
    • View Profile
Re: Problem with zipped roms?
« Reply #3 on: December 21, 2011, 08:23:48 PM »
It's a zip file but I noticed that there is a readme file in the folder that the emulator may be trying to open.
Device: Xperia Play 4g
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.3
App Version: xperia play beta v1. 1

Offline MusicNomad

  • bit
  • Posts: 5
    • View Profile
Re: Problem with zipped roms?
« Reply #4 on: December 21, 2011, 08:36:24 PM »
After removing the readme file the problem seemed to be solved. I'm not sure what the emulator defaults to if there's more than one file in the zipped folder.  All my zipped roms have this readme in them but only a few had the problem. Anyways, solution found :)
Device: Xperia Play 4g
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.3
App Version: xperia play beta v1. 1

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Problem with zipped roms?
« Reply #5 on: December 21, 2011, 10:10:00 PM »
This will be fixed in the next update.  I think this is what's causing most of the negative ratings, since Game Hunter produces zip files like this.  Thanks for pointing it out!
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted