Author Topic: Under "Change" no plugins are listed  (Read 4304 times)

Offline scorpio16v

  • long
  • ***
  • Posts: 203
    • View Profile
Under "Change" no plugins are listed
« on: December 22, 2011, 02:13:55 PM »
In another forum the problem came up, that under "Change" no plugins are listed.
The users hardware specs are : Xperia Play,root with stock 2.3.4.
Deleting and reload didn't help. The default plugins are set and some games are loading. But he can't see the plugin list.
Any ideas ?

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3495
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Under "Change" no plugins are listed
« Reply #1 on: December 22, 2011, 02:32:36 PM »
My initial thought is that the app isn't being installed to /data/data.  If that's the case, then it complicates a lot of other things (this assumption is made throughout the program..)  I'll do a little research to see if there are other locations that apps can be installed in Android.  I'll have to write a test for him to run to be sure if this is the problem.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Under "Change" no plugins are listed
« Reply #2 on: December 22, 2011, 02:58:48 PM »
I have the same issue, when I go to change a plugin no plugins are listed.
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Under "Change" no plugins are listed
« Reply #3 on: December 22, 2011, 03:57:23 PM »
Edit: its actually that i have both apps installed :P
« Last Edit: December 23, 2011, 08:23:39 AM by xperia64 »

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Under "Change" no plugins are listed
« Reply #4 on: December 22, 2011, 04:26:52 PM »
Plugins used to show up when mupen was saved to app-data.
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3495
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Under "Change" no plugins are listed
« Reply #5 on: December 22, 2011, 04:58:44 PM »
I have the same issue, when I go to change a plugin no plugins are listed.

Come to think of it, I know what the problem is.. I changed the package name for the Xperia Play version (required in order to list both on the Market), as well as for the test versions.  I'm surprised they showed up for anyone in the Xperia Play or test versions (it is pulling the list from the "normal" version, which permissions shouldn't allow).  Anyway, let me know if the libraries show up with this version (if not, please post a logcat):

Xperia Play, Missing Libs Fix
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Under "Change" no plugins are listed
« Reply #6 on: December 22, 2011, 06:26:00 PM »
I have the same issue, when I go to change a plugin no plugins are listed.

Come to think of it, I know what the problem is.. I changed the package name for the Xperia Play version (required in order to list both on the Market), as well as for the test versions.  I'm surprised they showed up for anyone in the Xperia Play or test versions (it is pulling the list from the "normal" version, which permissions shouldn't allow).  Anyway, let me know if the libraries show up with this version (if not, please post a logcat):

Xperia Play, Missing Libs Fix

That fixed it :)
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline scorpio16v

  • long
  • ***
  • Posts: 203
    • View Profile
Re: Under "Change" no plugins are listed
« Reply #7 on: December 23, 2011, 07:39:47 AM »
Thanks, I can report too, that the fix works.  :)