Author Topic: Zelda OOT start menu crash with gles2rice  (Read 10101 times)

Offline RedFox102

  • bit
  • Posts: 2
    • View Profile
Zelda OOT start menu crash with gles2rice
« on: March 07, 2013, 01:46:50 PM »
Forgive me if this is the wrong place for this, but I'm having a problem. When using gles2rice, oot crashes when exiting the start menu, however gles2n64 does not have this problem. The only way to change equipment is to save before exiting the menu, then restart the game. Also, I'm using default settings.  I'm running version 2.1.1 of mupen64 plus ae, and have reinstalled to make sure no settings were changed. I'm using a galaxy note 2, running stock 4.1.1, rooted. Cpu: Samsung exynos 4412,  Gpu: Mali400Mp. Any assistance would be appreciated, thanks.

« Last Edit: March 07, 2013, 01:50:13 PM by RedFox102 »

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Zelda OOT start menu crash with gles2rice
« Reply #1 on: March 07, 2013, 02:42:11 PM »
I'll test this on my phone later to see if I get the same problem.  Anyone else on here noticing this issue?
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Kris

  • Developer
  • int
  • *****
  • Posts: 91
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #2 on: March 08, 2013, 04:44:39 PM »
I haven't seen this but have heard about it from people working on emulators for the playbook and n9. It would be helpful to know the exact version of zelda that is being used including the hash.

Also I'm not sure if mupen64plus-ae uses the zelda subscreen fix cheat, my port only does it for a specific version of zelda.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Zelda OOT start menu crash with gles2rice
« Reply #3 on: March 08, 2013, 05:02:59 PM »
That's a good point about the subscreen fix cheat.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline RedFox102

  • bit
  • Posts: 2
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #4 on: March 08, 2013, 07:15:30 PM »
After further testing, I've concluded this crash only happens when using version 1.2 of the game. And I'm guessing the gamecube version would do this as well. But, 1.0 seems to work just fine.

Offline CatalystG

  • byte
  • *
  • Posts: 13
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #5 on: March 12, 2013, 11:51:59 AM »
This is something I am still seeing in my PlayBook and BlackBerry Z10 ports of Mupen with rice. In my case it doesn't crash, it just hangs with music playing. I've heard that the master quest zelda doesn't show this same behaviour so it may be dependent on the rom. I've disabled the subscreen fix so that shouldn't be the issue. I've been meaning to take a closer look at which roms cause it, and if any settings help (VI update, etc). I've seen this issue with OMAP and S4 based phones so it doesn't seem to be hardware based.

Offline jimmkd84

  • bit
  • Posts: 1
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #6 on: March 24, 2013, 09:01:03 PM »
hi all i am also getting the same problem using an acer iconia a500 oclocked to 1.5ghz. i have tried zelda oot 1.0 and 1.1 still get the same issues where the menu will freeze upon exit. seems to work fine with gles2n64 plugin but i would like to use rice as it seems to be more compatible with games

Offline Kris

  • Developer
  • int
  • *****
  • Posts: 91
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #7 on: March 25, 2013, 09:12:22 AM »
This doesn't happen on the touchpad version, but I can confirm it on android with the music continuing. Yoshi's Story doesn't work either and that game can work with rice.


I don't know if the subscreen fix prevents the crash or if the problem lies elsewhere, the Yoshi problem is related to the CRC code bits in Framebuffer.cpp. When I get a chance I'll take a look at the crash.

Offline CatalystG

  • byte
  • *
  • Posts: 13
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #8 on: March 26, 2013, 08:34:17 AM »
For BlackBerry at least, the subscreen fix doesn't solve the freeze.

Offline Rick

  • bit
  • Posts: 1
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #9 on: June 04, 2013, 02:59:53 AM »
Hello Paul,
First of all thanks for the app, I use Mupen64 Plus AE and it's great. Great to know your story too, made me buy the "plus" version.
I have the same problem that Redfox has, and I use a note 2 as well. I tried the 1.0 rom of OOT but it made no difference. So I play with the glide64 pugin which runs fine. But I'd like to be able to use the Djipi texture pack with the rice plugin.
Any way, keep at it, you're doing great.
Thx

Offline pirohmaniac

  • byte
  • *
  • Posts: 14
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #10 on: August 13, 2013, 05:09:08 PM »
I've noticed the problem on the Minix Neo X5 and G4, and my Xperia Play

Offline djsublime

  • bit
  • Posts: 6
    • View Profile
Re: Zelda OOT start menu crash with gles2rice ( workaround
« Reply #11 on: November 26, 2013, 07:35:33 PM »
I'm having the same issue on my lg optimus g pro,  oot v1.2,  when using  default settings on rice,  I've also noticed some textures are not loading (see picture) after some tinkering I've found that changing the screen update method to "Vi origin change"  resolves the problem but introduces some screen glitches when entering and leaving the start menu (see second picture), I am yet to try other versions of the rom.  I would love to use some high Def textures,  so,  does anybody have an idea?


Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #12 on: November 27, 2013, 08:57:03 AM »
That second picture looks like another symptom of the crappy Adreno drivers.  I've only seen that sort of thing on Adreno devices.
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline djsublime

  • bit
  • Posts: 6
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #13 on: November 27, 2013, 10:01:18 AM »
Actually my device is an LG optimus g pro which uses an adreno 320,  so is it the drivers then? Any ideas why that screen update setting fixes the start menu crash?

Offline Tsukuyomi

  • byte
  • *
  • Posts: 14
    • View Profile
Re: Zelda OOT start menu crash with gles2rice
« Reply #14 on: December 11, 2013, 10:11:03 PM »
I have that crash too...
It's a problem since it doesn't allow us to play using custom textures
And N64oid have problems on custom textures, it have some textures missing such as when Link blink his eyes, the original textures appear!!