Author Topic: Game speed has changed  (Read 36540 times)

Offline crab cakes

  • bit
  • Posts: 9
    • View Profile
Game speed has changed
« on: June 28, 2017, 10:08:42 AM »
Hi,

I have the N64 emulator from the Google Play Store.
Great job, it works very well and if there is a donation option I want to support this great app.

My question is, I decided to enable different video emulation profiles to see the difference(namely Glide accurate and I think the other one is super accurate, the one for powerful devices).
Any way it didn't work all that well so I enabled the old profile but I now notice Zelda OOT feels like it is running a bit fast. When I put the game back to 90% speed it feels right. But it resets to 100% each time I go into the game. The default is meant to be 100% right?
Any idea why this would be happening?

Thanks,

Offline Sobziiro

  • byte
  • *
  • Posts: 34
    • View Profile
Re: Game speed has changed
« Reply #1 on: June 28, 2017, 02:42:39 PM »
Thats sounds like frame skip activated in the plugin, create (or copy one of the profiles of glide64 an edit) and choose never skip frames in frame skip option.

Offline crab cakes

  • bit
  • Posts: 9
    • View Profile
Re: Game speed has changed
« Reply #2 on: June 28, 2017, 10:01:52 PM »
I did that and I feel it might be the same still.
It could be in my head as well so I might just leave it. New day  now and I am not sure if I was right and maybe the game was always that way.
« Last Edit: June 29, 2017, 10:10:52 AM by crab cakes »

Offline Sobziiro

  • byte
  • *
  • Posts: 34
    • View Profile
Re: Game speed has changed
« Reply #3 on: June 28, 2017, 11:56:53 PM »
If the game works at low fps and you feel that it is fast then the cause is the frameskip, both Zelda OOT and Majoras Mask run at maximum 20fps, also try to activate the audio synchronization maybe that helps.

Offline crab cakes

  • bit
  • Posts: 9
    • View Profile
Re: Game speed has changed
« Reply #4 on: June 29, 2017, 10:11:25 AM »
It runs at 20 fps all the time. I'll try that and report if it feels right after it.

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 514
    • View Profile
Re: Game speed has changed
« Reply #5 on: June 29, 2017, 09:37:08 PM »
20fps is the correct fps for the USA version of the game. Is that what you see when you enable the FPS display? Try going to settings then audio and disable "synchronize audio/video", maybe that will help.

On another note, frame skip will not make the emulator run at faster than 100% speed.
« Last Edit: June 29, 2017, 09:38:47 PM by fzurita »

Offline Sobziiro

  • byte
  • *
  • Posts: 34
    • View Profile
Re: Game speed has changed
« Reply #6 on: June 30, 2017, 04:05:14 PM »
So far I had not thought of it but maybe it is using the PAL version, this runs at 17 fps and that is why I feel it is going faster but if I am not mistaken it should be kept at 17 fps in the emulator, right?

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 514
    • View Profile
Re: Game speed has changed
« Reply #7 on: July 01, 2017, 12:56:19 AM »
Yeah, PAL version is 17 FPS

Offline crab cakes

  • bit
  • Posts: 9
    • View Profile
Re: Game speed has changed
« Reply #8 on: July 25, 2017, 03:40:24 AM »
Seems like it just went back to normal by itself. Maybe it was just in my mind.
Also it runs at 20 fps but I don't know if I got the PAL or NTSC.

Thanks for the help.