Author Topic: Need help finding a compatible version  (Read 1735 times)

Offline Blahmon

  • bit
  • Posts: 1
    • View Profile
Need help finding a compatible version
« on: August 26, 2017, 09:57:10 PM »
I just bought my father a Pandigital Novel (white) 7" w/ Android TM OS 2.0 . 

It doesn't have many things avaiable to it but was told that mupen64 might work for with that OS.

First, I tried installing the latest Mupen64 plus ae version 2.4.4  (the version i use in my android marshmallow) but it was incompatible. Then I downloaded an older mupen64 version (2.1.3), because that version was out about the same time as that device. For some reason after installing version 2.1.3 from sd card then booting, an error came up stating that usb had to be disconnected first and device rebooted (even though it wasn't connected by usb). 

Is there a compatible mupen64 for my dad's pandigital novel?... if so, which one?.... or anything comparable? 

Thank You For Your Help!!


Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 512
    • View Profile
Re: Need help finding a compatible version
« Reply #1 on: August 27, 2017, 07:42:36 PM »
Hello, that is so old, so maybe not.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3472
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Need help finding a compatible version
« Reply #2 on: August 27, 2017, 07:57:21 PM »
The problem is related to the fact that the Pandigital Novel uses onboard memory as storage.  IO operations that normally work with an external SD card fail.  This can usually be handled by using the getExternalStorageDirectory() function, which version 2.1.3 was already doing ( see https://github.com/mupen64plus-ae/mupen64plus-ae/blob/2.1.3/src/paulscode/android/mupen64plusae/persistent/AppData.java#L189 ).  However I recall that there were some devices that this didn't work on.  I can't recall if we were able to resolve this in a later version of the app, or if onboard memory was just better supported in later versions of Android.
« Last Edit: August 28, 2017, 07:14:24 AM by Paul »
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted