Author Topic: Runs Slow on Galaxy Ace  (Read 4538 times)

Offline maloi17s

  • bit
  • Posts: 2
    • View Profile
Runs Slow on Galaxy Ace
« on: December 18, 2011, 12:54:26 PM »
Hi Paul.Congratulations on successful alpha test.But i'm still having around 15 FPS in super mario 64 on my galaxy ace.Could that be possibly fixed somehow?

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3487
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Runs Slow on Galaxy Ace
« Reply #1 on: December 18, 2011, 01:12:39 PM »
It runs slow on ARM6 devices, unfortunately.  Performance will improve as the project progresses, but it won't happen over night.  It will take a lot of little optimizations over time.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Runs Slow on Galaxy Ace
« Reply #2 on: December 18, 2011, 01:16:04 PM »
In the meantime there are a few thing I believe you can disable to get a little performance boost.

1. go to skins >Virtual gamepad settings
And disable "Display FPS"

2. Go to change and change it to "mupen64plus-ae-touch-(whatever size you want to use)"

3. Go into the audio settings and disable the audio plugin.
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3487
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Runs Slow on Galaxy Ace
« Reply #3 on: December 18, 2011, 01:17:24 PM »
4. Go to Settings->RSP change it to "librsp-hle-nosound.so".  Will give a slight performance improvement if the sound is already disabled anyway.

5. Go to Settings->Video->Configure, and disable "Stretch Screen"

6. Go to Settings->Video->Configure, disable "Auto Frameskip", and increase "Max Frameskip" (play around with different values to find what works best)
« Last Edit: December 18, 2011, 01:20:31 PM by Paul »
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted