Author Topic: 3.0 Alpha Testing  (Read 295343 times)

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: 3.0 Alpha Testing
« Reply #720 on: June 17, 2015, 10:33:13 PM »
Thanks Gilles for the CBFD fix, and thanks retroben for finding it right away :)

I updated the OP to Alpha 21.  Identical to Alpha 20 but fixes CBFD.
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline studiosound

  • bit
  • Posts: 3
    • View Profile
Re: 3.0 Alpha Testing
« Reply #721 on: June 18, 2015, 12:47:41 PM »
I've been going through my catalog to see if everything works, and I can't get Turok 2 (u)1.0 or Turok 3 (U) to boot in this new alpha 21. I've tried several different versions of the files to no avail. They worked previously in current Mupen64+ and 2.5 beta as well as previous 3 alphas. Anyone else have that issue? Every other game that previously worked still boots and the new file selection process is nice.
I also can't get the new GlideN64 2 settings to go to anything other than a black screen, including changing my audio to the new sles version. Is there a trick to it, or is it the x86 of my tablet the culprit? I understand it's bleeding edge stuff, but I may be doing it wrong.
Dell Venue 3830 x86 4.4.2
« Last Edit: June 18, 2015, 12:54:04 PM by studiosound »

Offline retroben

  • float
  • ****
  • Posts: 432
    • View Profile
Re: 3.0 Alpha Testing
« Reply #722 on: June 18, 2015, 02:47:49 PM »
It's an x86 issue for GLideN64 because my x86 tablet also fails to run that plugin.

The Turok crashing might be related to x86 differences since Castlevania crashes on x86 while my FireTV runs it fine via ARM.

According to the logcat,GLideN64's non-running black screen is caused by the GL Context immediately being destroyed just after creation,halting the boot process.
The other GFX plugins work fine though.
Maybe Gillou can try to find a fix for this?

Offline Gillou68310

  • Developer
  • long
  • *****
  • Posts: 112
    • View Profile
Re: 3.0 Alpha Testing
« Reply #723 on: June 19, 2015, 01:51:52 AM »
I just tested turok, turok2 and castlevania with new dynarec on windows x86 with no issues. @retroben could you test again all 3 games with latest autobuild?

Offline retroben

  • float
  • ****
  • Posts: 432
    • View Profile
Re: 3.0 Alpha Testing
« Reply #724 on: June 19, 2015, 12:14:10 PM »
I was talking about my Android x86 tablet.

Castlevania still crashes on Android x86 with "unfortunately" error box on the latest build.

In logcat I get:
Code: [Select]
Fatal signal 11 (SIGSEGV) at 0xffffff2d (code=1), thread 2529 (CoreThread)
Also this neat sentence...
Hello, this is UFO GRALLOC/Intel Corporation

Offline Gillou68310

  • Developer
  • long
  • *****
  • Posts: 112
    • View Profile
Re: 3.0 Alpha Testing
« Reply #725 on: June 19, 2015, 02:07:26 PM »
I was talking about my Android x86 tablet.

Sure, me too ;)

I'd like to understand why it crashes an android x86 while it works just fine on windows x86 (still need to check on linux x86)

Could you send me castlevania's rom md5?

Where does it craches exactly?

Also could you test with pure interpreter just to be sure it's dynarec related?

Last question do you recall if this was also happening with old dynarec?
« Last Edit: June 19, 2015, 02:12:18 PM by Gillou68310 »

Offline alexei_gp

  • bit
  • Posts: 1
    • View Profile
Re: 3.0 Alpha Testing
« Reply #726 on: June 19, 2015, 08:36:09 PM »
Where is the alpha 21?  i cant find it ...i m asking this because i tested this apk named mupen64 master  version 2015-06-18 09:03(commit a9b9e1e) and i cant access on the emulator mupen the microsd storage on my nvidia shield portable.I get that apk in this link newbielink:http://www.paulscode.com/source/Mupen64Plus-AE/AutoBuilds/ [nonactive]

Another bug with the apk mupen64 master  version 2015-06-18 09:03(commit a9b9e1e) the emulator doesnt detect any buttons on the nvidia shield portable.only works the touch screen.
« Last Edit: June 19, 2015, 09:25:25 PM by alexei_gp »

Offline retroben

  • float
  • ****
  • Posts: 432
    • View Profile
Re: 3.0 Alpha Testing
« Reply #727 on: June 19, 2015, 10:29:25 PM »
Castlevania crashes in the same place it always has,at the first skeleton cutscene.

The MD5 checksum via ES File Explorer is: 1cc5cf3b4d29d8c3ade957648b529dc1

I've tried running it in the past when on an older version of Mupen.

Can't test interpreter until a little later.
« Last Edit: June 19, 2015, 10:31:00 PM by retroben »

Offline studiosound

  • bit
  • Posts: 3
    • View Profile
Re: 3.0 Alpha Testing
« Reply #728 on: June 20, 2015, 12:07:16 AM »
To be clear, Turok 1 boots. It's Turok 2 (U) 1.0 and Turok 3(u) that either don't boot or boot to black and freeze in the current listed Android build posted by the dev at the very top of this thread. Both dynarec and  interpereter have the same result of booting to black for me. The earlier posted Android MupenAE+ builds from the original post booted those particular clean roms.

Turok 3 (U) MD5
1211c556d77b169d81a666a9661e1777

Turok 2 (U) 1.0 MD5
fad4da8e17ce12f68cdf29180cdd4a90

Dell Android x86 4.4.2
« Last Edit: June 20, 2015, 12:09:30 AM by studiosound »

Offline retroben

  • float
  • ****
  • Posts: 432
    • View Profile
Re: 3.0 Alpha Testing
« Reply #729 on: June 20, 2015, 12:18:35 AM »
Are you using GLideN64 on the profiles by any chance?
You might have accidentally had them set to it,as I have done that a few times myself.

Make sure they are both using Glide64,Rice,or glN64 to make sure you didn't have the silly things on GLideN64.

I wonder what is causing GLideN64's issues to begin with.
Why is it destroying GL Context immediately after creation?

Offline studiosound

  • bit
  • Posts: 3
    • View Profile
Re: 3.0 Alpha Testing
« Reply #730 on: June 20, 2015, 08:21:27 AM »
I'm using using the Glide64 accurate, or any of the other, usually working emulation profile. I've defaulted my settings, I've changed profiles...note that every other rom using the same settings that previously worked still boots as expected. The only two games that don't boot like they used to are Turok 2 (u) and 3 (u), and only on my Dell Venue 3830 Android tablet. Files unzipped. Older versions of the Android Mupen ae+ still boot Turok 2 and 3 just fine.

I'm not bothering with the GlideN64 GLES as no games boot using it on my x86 tablet, running Android 4.4.2.

My last attempt later will be to clear out the beta and do a clean install. We shall see.
« Last Edit: June 20, 2015, 08:30:35 AM by studiosound »

Offline Gillou68310

  • Developer
  • long
  • *****
  • Posts: 112
    • View Profile
Re: 3.0 Alpha Testing
« Reply #731 on: June 21, 2015, 04:46:11 AM »
Quote
Older versions of the Android Mupen ae+ still boot Turok 2 and 3 just fine.

If you can find which version exactly introduced this issue this will be very helpfull ;)
« Last Edit: June 21, 2015, 04:49:11 AM by Gillou68310 »

Offline Metalmusic3000

  • byte
  • *
  • Posts: 47
    • View Profile
Re: 3.0 Alpha Testing
« Reply #732 on: June 22, 2015, 08:07:52 PM »
Hi iam just starting to learn about texture packs can anyone tell me a good place to download some perhaps for goldeneye are shadows of the empire i have a few for super mario 64 i havent seen any for those games yet

Offline Donlavon1

  • bit
  • Posts: 3
    • View Profile
Re: 3.0 Alpha Testing
« Reply #733 on: June 23, 2015, 01:03:27 AM »
just google 'N64 textures' and you should find them. I don't think you can use textures on the latest beta builds yet.

Offline marc

  • bit
  • Posts: 3
    • View Profile
Re: 3.0 Alpha Testing
« Reply #734 on: June 25, 2015, 02:47:07 AM »
good morning,
is there any solution for the crash of banjo tooie?
I tried in every way but nothing, always crash!