Author Topic: 3.0 Alpha Testing  (Read 295593 times)

Offline retroben

  • float
  • ****
  • Posts: 432
    • View Profile
Re: 3.0 Alpha Testing
« Reply #540 on: January 27, 2015, 02:27:18 PM »
Hires textures (the 3ds texture mod 0.7 beta) for Zelda Ocarina 1.0 are not loading in the latest Alpha.
The "famous" build loads them just fine. *snicker*

Edit:Checked the stable 2.4.4 and no hires textures are loading and now also the Alpha is no longer loading the Banjo-Tooie hires texture pack either. (it loaded before on the same Alpha)
It used to load them,but now is not working for some stupid reason.

The only one that works for hires textures is that one build by Gillou.
We really need that source data!
« Last Edit: January 27, 2015, 02:39:17 PM by retroben »

Offline rafar

  • int
  • **
  • Posts: 67
    • View Profile
Re: 3.0 Alpha Testing
« Reply #541 on: January 27, 2015, 02:32:26 PM »
I tested the last build with crash exit fixes, and I had a lot of problems with mario 64. While I was testing the game, Mario is lying on the floor, the sound crashes and finally when I go out of the game, crashes as usually.


Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: 3.0 Alpha Testing
« Reply #542 on: January 27, 2015, 02:52:15 PM »
The only one that works for hires textures is that one build by Gillou.

But the odd thing is that Gilles didn't modify any of the hi-res texture loading stuff.

Just to be clear, hi-res textures only work with the Rice video plugin.  When you say hi-res textures don't work, does the app just use the normal built-in textures and play like normal, or does the app do something strange instead?

We really need that source data!

I have the source.  As I've said before it's available as separate branches on my fork for anyone to see:
https://github.com/littleguy77/mupen64plus-ae/branches/all
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: 3.0 Alpha Testing
« Reply #543 on: January 27, 2015, 02:57:56 PM »
I tested the last build with crash exit fixes, and I had a lot of problems with mario 64. While I was testing the game, Mario is lying on the floor, the sound crashes and finally when I go out of the game, crashes as usually.

Thanks much.  You and xperia64's reports are helping me isolate the problem.  I did some more debugging on this last night and I may have a few more avenues to explore on this.  One that's relatively easy to test is a race between the input plugin and the ae-bridge.  I'll try to post another test build soon.

@rafar - Were you having the crash-on-exit bug with the Alphas as well, or just that test build?
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline retroben

  • float
  • ****
  • Posts: 432
    • View Profile
Re: 3.0 Alpha Testing
« Reply #544 on: January 27, 2015, 03:05:15 PM »
It just loads normally without the hires textures intact.
I can't help but blame Qualcomm and/or Adreno for this annoyance.

The pack I am using was tested on Android already because of screenshots on N64oid.

http://forums.zelda64.net/topic/10473840/1/

And I know I have it in the right folder because Banjo-Tooie hires textures were already imported and worked on the Alpha at one point when enabled by accident from a default rice-balanced profile.

Offline rafar

  • int
  • **
  • Posts: 67
    • View Profile
Re: 3.0 Alpha Testing
« Reply #545 on: January 27, 2015, 04:51:13 PM »
I tested the last build with crash exit fixes, and I had a lot of problems with mario 64. While I was testing the game, Mario is lying on the floor, the sound crashes and finally when I go out of the game, crashes as usually.

Thanks much.  You and xperia64's reports are helping me isolate the problem.  I did some more debugging on this last night and I may have a few more avenues to explore on this.  One that's relatively easy to test is a race between the input plugin and the ae-bridge.  I'll try to post another test build soon.

@rafar - Were you having the crash-on-exit bug with the Alphas as well, or just that test build?


I dont know how but at now I can not get mario lying on the floor as I said before, but I have several pics, later I will edit this post. Moreover, the audio neither crashed as I said previusly.

It is really difficult to assert when I have a crash-on-exit, I have tested for 10 or 12 times and only crashed twice, very close to test build results I get.

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: 3.0 Alpha Testing
« Reply #546 on: January 27, 2015, 05:43:31 PM »
When mario was lying on the floor, does that mean you couldn't control him?
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline rafar

  • int
  • **
  • Posts: 67
    • View Profile
Re: 3.0 Alpha Testing
« Reply #547 on: January 28, 2015, 02:44:13 AM »
Yes, mario can move and also jump. This happened to me only the first time I tested the last build crash-on-exit.



I moved him around the castle.



And here he is jumping.



I say this if it could be useful for you about the crash on exit.
« Last Edit: January 28, 2015, 03:06:48 AM by rafar »

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: 3.0 Alpha Testing
« Reply #548 on: January 28, 2015, 07:38:33 PM »
LOL  ;D :o

Of all the crazy bugs I've seen on this forum, this is easily the funniest!

Fortunately it's only in an experimental test build.  More signs pointing to state not being cleared between launches.
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: 3.0 Alpha Testing
« Reply #549 on: January 29, 2015, 07:53:33 AM »
Alpha 17 published.  Link and change log are shown on the OP.

Some of the fixes from the test builds have been officially integrated (audio latency and rice fixes).  Gilles' optimizations are NOT in Alpha 17 yet since they are not upstream yet.

The global settings were streamlined just a tad.  You may want to double check your "joystick animation" and "display framerate" settings after you upgrade.

Bugs in Rice video should only be compared to version 2.4.4 on the Play store.  Do not bother using or comparing Rice in Alphas 1-16.
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline rafar

  • int
  • **
  • Posts: 67
    • View Profile
Re: 3.0 Alpha Testing
« Reply #550 on: January 29, 2015, 11:46:32 AM »
well done, mario 64 sync is good with rice, both banjo tooie and banjo kazooie dont have so good sync as mario 64 (I only tested that 3 games)

until now I have not seen any crash on exit  ;D

Offline retroben

  • float
  • ****
  • Posts: 432
    • View Profile
Re: 3.0 Alpha Testing
« Reply #551 on: January 29, 2015, 12:36:07 PM »
Super Smash Bros. is not flickering the entire screen with garbage anymore,but still has the outer edges covered with it.
This happens in other emulators,so not much more you can do about it.

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: 3.0 Alpha Testing
« Reply #552 on: January 29, 2015, 06:48:45 PM »
I'm not sure if it's been on all the Alphas, but saving custom cheats with options is broken. Saving regular custom cheats works, but if I set the value to ???? and add some options, it doesn't save. I'll try to look into that soon.

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: 3.0 Alpha Testing
« Reply #553 on: January 29, 2015, 07:18:31 PM »
Sounds good.  You should definitely take the lead since I am pretty useless on the cheats UI.  Hopefully git-bisecting will narrow it down quickly.

On another note, I added a fair bit more error logging in ae-bridge for Alpha 17.  In case there are any clues on your crashing.  You might need to log with an external app or PC though.  I discovered that native segfaults and stuff do not get percolated up as java exceptions, hence they do not trigger the crash handler to persist the log to disk.  There may be some workarounds that I can try, at least on a test branch.
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline retroben

  • float
  • ****
  • Posts: 432
    • View Profile
Re: 3.0 Alpha Testing
« Reply #554 on: February 05, 2015, 01:32:19 AM »
@xperia64: Just re-found out that ClassicBoy has realtime cheats access which worked on N64 with Banjo-Tooie and my "no frameskip" code when I tested it disabled then enabled to make it reach 60fps from the original framerate.
You could probably look at it to see how it was done.