Author Topic: SoundSystem [LWJGLOpenAL]  (Read 3026 times)

Offline Javis

  • bit
  • Posts: 4
    • View Profile
SoundSystem [LWJGLOpenAL]
« on: January 04, 2015, 08:20:21 AM »
What did i do wrong ?
I linked LWJGL like in the guide from the website and i got this error on startup from the sound system
Code: newbielink:javascript:void(0); [nonactive]
Exception in thread "Thread-0" java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
at java.lang.Class.getMethod0(Unknown Source)
at java.lang.Class.getMethod(Unknown Source)
at paulscode.sound.SoundSystemConfig.runMethod(SoundSystemConfig.java:900)
at paulscode.sound.SoundSystemConfig.getLibraryTitle(SoundSystemConfig.java:321)
at paulscode.sound.SoundSystem.CommandNewLibrary(SoundSystem.java:1524)
at paulscode.sound.SoundSystem.CommandQueue(SoundSystem.java:2572)
at paulscode.sound.CommandThread.run(CommandThread.java:121)
Caused by: java.lang.ClassNotFoundException: org.lwjgl.LWJGLException
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 9 more
I need fast help!
Please ;D

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3473
  • Developer
    • View Profile
    • PaulsCode.Com
Re: SoundSystem [LWJGLOpenAL]
« Reply #1 on: January 04, 2015, 10:00:19 AM »
That error is fairly generic.  It means that LWJGL was not found in the class paths.  Fixing the problem depends on how you are building the project.  If you google "java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException" you will find various folks who have had this error and the solutions that worked for them based on their particular scenario.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Javis

  • bit
  • Posts: 4
    • View Profile
Re: SoundSystem [LWJGLOpenAL]
« Reply #2 on: January 04, 2015, 11:28:11 AM »
Ok ..
I told Eclipse were the native files are but im still getting this error.
Futhermore .. i tryed to get the example LWJGL programm run and it worked perfect.
I realy dont no what i did wrong?
Do i have to make any aditional imports?(And yes i already imported paulscode.sound.libraries.LibraryLWJGLOpenAL;)
« Last Edit: January 04, 2015, 11:46:51 AM by Javis »

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3473
  • Developer
    • View Profile
    • PaulsCode.Com
Re: SoundSystem [LWJGLOpenAL]
« Reply #3 on: January 04, 2015, 12:10:39 PM »
The error indicates the class org/lwjgl/LWJGLException was not recognized.  This only happens if the class paths are not set up correctly.  If you can build the example LWJGL programs, then I would recommend comparing the settings to make sure they match.

I haven't used LWJGL in some time myself, but based on the JavaDoc, the LWJGLException class hasn't moved.  http://legacy.lwjgl.org/javadoc/org/lwjgl/LWJGLException.html
« Last Edit: January 04, 2015, 12:12:27 PM by Paul »
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Javis

  • bit
  • Posts: 4
    • View Profile
Re: SoundSystem [LWJGLOpenAL]
« Reply #4 on: January 04, 2015, 12:29:00 PM »
I did and everything matched.
I also tryed to initialize the Soundsystem within the example but still the same error

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3473
  • Developer
    • View Profile
    • PaulsCode.Com
Re: SoundSystem [LWJGLOpenAL]
« Reply #5 on: January 04, 2015, 02:39:38 PM »
Hard to say.  Definitely something wrong with the project settings.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted