Author Topic: Yoshi story- Zelda OOT- 007  (Read 2318 times)

Offline Gomex19

  • bit
  • Posts: 7
    • View Profile
Yoshi story- Zelda OOT- 007
« on: January 22, 2012, 11:52:25 PM »
have had the app for a few weeks and decided to try some more games

Yoshi- absoluetly everything is wrong except the beginning when the book opens and the acual green character yoshi and his movements.. everything else is graphicly distroyed..

Zelda 00T is a huge one ik people realaly want to work, mine works great accept, at the begging right in links house its all polycolor stuff then when i hit "start" it acually shows that room correctly even if im not in that room, then goes to the pause menu, the pause menu is fine accept i cant see the picture of link.. also two, i can never see my rupees? kinda weird. then finnaly i got to the shop to buy the sheild and it was the same as the first room in the game, all buggyed out.. any ideas?
will overclock help?

finally 007, controls are tricky but good, and gameplay is great but slightly laggy, easy fix once i overclock.
Phone=Thrill 4G- AKA: LG Optimus 3D
- Operating System: Android 2.2(rooting soon to Icecream..
- RAM: 512 MB
- Processor: 1GHz(overclocking soon)
Resolution: 480X800
- Size: 4.3-inches

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Yoshi story- Zelda OOT- 007
« Reply #1 on: January 23, 2012, 08:04:53 AM »
Zelda 00T is a huge one ik people realaly want to work, mine works great accept, at the begging right in links house its all polycolor stuff then when i hit "start" it acually shows that room correctly even if im not in that room, then goes to the pause menu, the pause menu is fine accept i cant see the picture of link.. also two, i can never see my rupees? kinda weird. then finnaly i got to the shop to buy the sheild and it was the same as the first room in the game, all buggyed out.. any ideas?
will overclock help?

Overclocking will not help with the Zelda OOT problems.  There are 3 separate problems in this game.  The solid-color rooms are the biggest one, and will be the first game-specific bug that I tackle (it is currently #5 on my priority list, after some device compatibility and stability issues and the make-file problem).  I know where the problem is occurring in the code, I just have to figure out why (no idea yet how difficult it will be to fix).  The missing rupee count is related to the Alpha Test code (disabling Alpha Test in the menu will make it visible).  I'm hoping when I solve the Alpha Test bug that's happening on some devices, it might fix this problem too.  If it is the same problem, then this is #1 on my priority list.  If it turns out to be something else, it will end up lower on my priority list, because it isn't a game-killer (more of an annoyance).  The missing Link image in the inventory is due to one of the N64 framebuffer modes not being emulated.  Virtually no N64 emulator has this right.  There is only on video plug-in that I know of in existence (Jabo's Direct3D plugin for Project64) which emulates this properly (and it is closed-source).  Therefore this problem has a much lower priority than the other two (since it is a very high difficulty with a very low benefit).  I will tackle the problem at some point, but there are more serious things that would be less difficult to fix first.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted