Author Topic: Latest Build! [CLOSED]  (Read 80380 times)

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3473
  • Developer
    • View Profile
    • PaulsCode.Com
Latest Build! [CLOSED]
« on: December 01, 2012, 07:59:48 PM »
This thread is now closed
Version 2.0 Release Candidates are being stress-tested in this thread.  Please help with the testing!

Latest builds:
(commit #4e556084fe)

- Release Optimized (3 Jan 2013)

- Debug Build (3 Jan 2013) **Use this build for crash reports**


Older builds:

- Release Optimized (22 Dec 2012)
- Debug Build (22 Dec 2012)

- Release Optimized (21 Dec 2012)
- Debug Build (21 Dec 2012)

- Release Optimized (15 Dec 2012)
- Debug Build (15 Dec 2012)

- Release Optimized (12 Dec 2012)
- Debug Build (12 Dec 2012)

- Release Optimized (09 Dec 2012)
- Debug Build (09 Dec 2012)

- Release Optimized (01 Dec 2012)

- Debug Build (03 Dec 2012)

- Debug Build (04 Dec 2012)

Use the release-optimized builds for performance tests.  If you do happen to find new crashes that you didn't used to experience, or if you are submitting a logcat for review, please use the slower debug builds for that.

If everyone could spread the word about Mupen64Plus AE on your social networks, it would be very helpful, to help breath life back into the forum here and get more testers to help out as we approach the Beta 2.0 release!

List of bugs reported and being looked into
- App crashes immediately on Froyo.
- Rice stretch screen is opposite to preference
- Rice unstretched is not centered
- Rice unstretched has junk graphics on side of screen for some devices
- GLES2N64 auto frameskip doesn't appear to be working
- GLES2N64 is slower for Mario64 than previous build
- GLES2N64 frameskip preference dialog doesn't scroll (can't select some options on smaller screens)
- Virtual gamepad analog stick immobile
- On/ off button for gamepads switches back off when leaving or toggling volume key controls
- Selecting "Main Menu" from in-game menu either quits or crashes the app
- No "reset" function in-game
- Reset function is crashing the game again
- Cheats option does nothing
- Orientation change erases cheat menu options
- Import texture pack option does nothing
- Xperia Play touchpad options missing from Settings->Touch on some Xperia Plays (or possibly difficult to find)
- When loading each game for the first time it crashes but runs fine after the second try
- Emulator crashes if you open and close the xperia play gamepad controls.
- Emulator crashes if you have landscape mode selected but are holding the phone in portrait at startup
- 'Gamepad/keyboard' option refuses to stay enabled
- When entering settings, nothing gives touch responses.  Have to go back then press settings again
- Input from IMEs not interpreted properly
- Core functions not functioning

If you find a bug that's not on the list, or if one is fixed and I forgot to strike it off, let me know!
« Last Edit: January 07, 2013, 09:53:52 PM by Paul »
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: Latest Build!
« Reply #1 on: December 01, 2012, 08:36:29 PM »
You should make a fb page for the project.  I just liked ouya's page yesterday
 8)
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Latest Build!
« Reply #2 on: December 01, 2012, 08:56:38 PM »
REALLY fast but found a couple of issues so far:
Mapping buttons is confusing (and what are the light grey buttons in the bottom center?)
gles2rice stretch enabled shows the game in the left 3/4 of the screen, then in the other 1/4 of the screen, 2 smaller "screens" show the bottom right corner of the real screen repeated.
Pressing Main Menu autosaves and quits the app
Portrait doesn't work
Edit: with stretch disabled, it stretches normally.
« Last Edit: December 01, 2012, 08:59:33 PM by xperia64 »

Offline Evil King Stan

  • byte
  • *
  • Posts: 33
    • View Profile
Re: Latest Build!
« Reply #3 on: December 01, 2012, 08:59:35 PM »
How do you enable Xperia Play gamepad on this version? I can't seem to find that option anywhere in the settings. Also, it seems just a tad slower on gles2n64 video plugin now, (first time I've seen frame skipping on Mario 64 in a long time.) I like the new menu layout though.

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Latest Build!
« Reply #4 on: December 01, 2012, 09:01:09 PM »
How do you enable Xperia Play gamepad on this version? I can't seem to find that option anywhere in the settings. Also, it seems just a tad slower on gles2n64 video plugin now, (first time I've seen frame skipping on Mario 64 in a long time.) I like the new menu layout though.
xperia play touchpad is in settings->Touch

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: Latest Build!
« Reply #5 on: December 01, 2012, 09:05:29 PM »
Yeh very likely the button mapping will back to something like before . Top of my todo list atm
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3473
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Latest Build!
« Reply #6 on: December 01, 2012, 09:10:31 PM »
How do you enable Xperia Play gamepad on this version? I can't seem to find that option anywhere in the settings. Also, it seems just a tad slower on gles2n64 video plugin now, (first time I've seen frame skipping on Mario 64 in a long time.) I like the new menu layout though.

Are you using an Xperia Play, I assume?  If so, and the touchpad settings aren't there, could you look up what says in Settings->Advanced->Device Info in the "Hardware" section near the bottom?

Also, check if disabling the virtual gamepad helps any with the speed.  -- EDIT-- sorry, it is called "Touchscreen" now, in Settings->Touch.  Just uncheck it.
« Last Edit: December 01, 2012, 09:13:31 PM by Paul »
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Latest Build!
« Reply #7 on: December 01, 2012, 09:15:36 PM »
YES! DK64 WORKS!
and even though you've seen it before, here is the banjo-tooie crash logcat yet again: http://pastebin.com/SNDrv8k9

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3473
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Latest Build!
« Reply #8 on: December 01, 2012, 09:25:09 PM »
I'll have to post a debug build so I can use addr2line.  I'll take a look at that crash again once we get the update complete.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: Latest Build!
« Reply #9 on: December 01, 2012, 09:43:21 PM »
Figures, the weekend I'm out of town everything hits the fan  :P

Actually having problems with the XPlay touchpad in the release build all of the sudden... strange.
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3473
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Latest Build!
« Reply #10 on: December 01, 2012, 09:45:40 PM »
Sorry about that!  This is the first weekend I've had off in a while, so that's why I've been getting a little crazy with the project today.  You definitely deserve a ton of credit for all the awesome work you've done with this front-end!!
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline littleguy

  • Moderator
  • double
  • *****
  • Posts: 1945
    • View Profile
Re: Latest Build!
« Reply #11 on: December 01, 2012, 09:55:51 PM »
No apologies! Glad you're getting a little free time...I'm just feeling all cooped up in this hotel while everyone else is having fun ;D
2012 Nexus 7, rooted stock Lollipop
Samsung Galaxy Victory, rooted stock Jelly Bean
Xperia PLAY, stock Gingerbread
OUYA, retail version

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Latest Build!
« Reply #12 on: December 01, 2012, 11:02:30 PM »
Touchpad works fine for me, but I'm om 2.3.3 if that makes any difference. And I also noticed gles2n64 auto frameskip doesn't seem to work and its a bit slower. Still working on compatibility chart. Animal Forest runs pretty well :)

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3473
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Latest Build!
« Reply #13 on: December 01, 2012, 11:34:29 PM »
Yes, seems like something is missing on that screen.  Should be able to set the max frames skipped when Auto is selected.  Seems to be just auto default (2 probably?) and a list of manual frame skip choices.

Might be able to fix it by making "Auto" a checkbox, and the rest radio buttons on that dialog if it's editable like that (I'll have to look at the code where it gets generated).  I'll also check to make sure selected settings make it through to the native side where it's used, to rule out any problems there.
« Last Edit: December 02, 2012, 12:21:55 AM by Paul »
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline arrtoodeetoo

  • byte
  • *
  • Posts: 34
    • View Profile
Re: Latest Build!
« Reply #14 on: December 02, 2012, 12:45:58 AM »
I found a major bug (possibly).

I'm using a Motorola XOOM on Android 4.1.

I'm trying to set up PS3 controllers with the Sixaxis app. I've previously been able to do this on the older version of Mupen, but you've changed the scheme for setting buttons on this version. I like the new setup but it doesn't work!

When I open the input settings, I am greeted with a nice clean screen to turn on the gamepads I want to use. Ok, cool. So I turn one on. I hit configure, pull up the controller graphic thingy, touch a button and NOTHING HAPPENS! No matter how many times I press it, I get nothing but a quick flash of blue over the button. I see nothing that says "Press a button on gamepad" or the like, and pressing a button on the PS3 Controller doesn't do anything, either.

Also a huge annoyance I foresee: The on/off button for the gamepads should stay on or off all the time. When I leave the screen or even toggle "Volume Key Controls", they all switch back off. It would be very annoying to have to switch the controllers on every time you start the app.

I've had a ton of fun with Mupen in the past and am looking forward to testing this update once I can get my controllers mapped out (and actually keep them turned on when I leave the screen!). I hope this problem can get fixed soon. Thanks for the great app!
« Last Edit: December 02, 2012, 12:47:52 AM by arrtoodeetoo »