Author Topic: app crashing on startup (NVidia Shield TV)  (Read 3356 times)

Offline ChancellorFluffy

  • bit
  • Posts: 5
    • View Profile
app crashing on startup (NVidia Shield TV)
« on: December 08, 2015, 07:41:09 PM »
I recently installed the alpha app (commit f8da4c1 from 11/15/2015) on my NVidia Shield TV. I use Kodi/xbmc's Rom Collection Browser addon to access the app and run games on it. Specifically, to see if the app worked I ran Mario Kart 64. It seemed to run smoothly enough, so I closed the app (back button, brings up end emulation menu, click yes). Since then it crashes on startup. Uninstalling and reinstalling the app did not fix this. Uninstalling the app, cleaning out the app data, then reinstalling it works, but it once again crashes after one game run and trying to start it up again. Basically, the app will only ever work one time then I have to uninstall it and delete all app data in order to reinstall it and get it to work again.

Is this something others are experiencing or is it unique to me? i.e. is this just because of using an NVidia Shield TV or because I am accessing the app through Kodi?

I'd like to get the app running successfully and without crashing. I'll be glad to provide any information asked for about my setup as long as I understand what I'm being asked for!

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 578
    • View Profile
Re: app crashing on startup (NVidia Shield TV)
« Reply #1 on: December 08, 2015, 09:36:36 PM »
I recently installed the alpha app (commit f8da4c1 from 11/15/2015) on my NVidia Shield TV. I use Kodi/xbmc's Rom Collection Browser addon to access the app and run games on it. Specifically, to see if the app worked I ran Mario Kart 64. It seemed to run smoothly enough, so I closed the app (back button, brings up end emulation menu, click yes). Since then it crashes on startup. Uninstalling and reinstalling the app did not fix this. Uninstalling the app, cleaning out the app data, then reinstalling it works, but it once again crashes after one game run and trying to start it up again. Basically, the app will only ever work one time then I have to uninstall it and delete all app data in order to reinstall it and get it to work again.

Is this something others are experiencing or is it unique to me? i.e. is this just because of using an NVidia Shield TV or because I am accessing the app through Kodi?

I'd like to get the app running successfully and without crashing. I'll be glad to provide any information asked for about my setup as long as I understand what I'm being asked for!

I would be glad to help. Can you post the files in this directory?

/sdcard/mupen64plusae-v3-alpha/CrashLogs

Post all the files that start with Crash_*.


Offline ChancellorFluffy

  • bit
  • Posts: 5
    • View Profile
Re: app crashing on startup (NVidia Shield TV)
« Reply #2 on: December 08, 2015, 10:13:15 PM »
Here are my crash logs. I think I have a hypothesis about what happened. My ROMS are stored on a media server. When a game on a media server is selected in Kodi/Rom Collection Browser, the game is temporarily loaded into a local temp directory stored inside a hidden folder (/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/...). I wonder if Mupen is trying to access that folder to show the n64 games in it after closing the active game. I have noticed that you can't normally choose a hidden directory in your games path when you click that refresh-looking button to choose a path to load games from. I am thinking that trying to get into that temp folder in a hidden directory is what's causing the crash.

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 578
    • View Profile
Re: app crashing on startup (NVidia Shield TV)
« Reply #3 on: December 08, 2015, 11:03:41 PM »
There seems to be something strange about your romInfoCache.cfg file.

Can you post this file:

/sdcard/mupen64plusae-v3-alpha/GalleryCache/romInfoCache.cfg.

Also, in the mean time, I added a null check to the code to check for this condition and made a local build. This build can be found here:

https://drive.google.com/file/d/0B57Ioy26LWegNE85RFhXdnc1SGM/view?usp=sharing

To install this build, you will have uninstall your current version first.

This build may not totally fix the problem since I will not know the root cause of the problem until you post the romInfoCache.cfg file.

Offline ChancellorFluffy

  • bit
  • Posts: 5
    • View Profile
Re: app crashing on startup (NVidia Shield TV)
« Reply #4 on: December 09, 2015, 07:27:13 AM »
I will certainly post that file when I get home this evening.

Offline ChancellorFluffy

  • bit
  • Posts: 5
    • View Profile
Re: app crashing on startup (NVidia Shield TV)
« Reply #5 on: December 09, 2015, 04:10:37 PM »
As requested, my romInfoCache.cfg. Also, the build you provided seems to have fixed the problem, or at least put a band-aid on it. I am no longer experiencing the issue I previously described.

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 578
    • View Profile
Re: app crashing on startup (NVidia Shield TV)
« Reply #6 on: December 09, 2015, 07:02:31 PM »
Thanks, that file you just gave me allowed me to get to the root cause of the problem. I will submit a fix.

Offline ChancellorFluffy

  • bit
  • Posts: 5
    • View Profile
Re: app crashing on startup (NVidia Shield TV)
« Reply #7 on: December 09, 2015, 10:01:04 PM »
You have my thanks.