Author Topic: Alpha Testing Underway!  (Read 328704 times)

Offline roymustang16

  • byte
  • *
  • Posts: 12
    • View Profile
Re: Alpha Testing Underway!
« Reply #390 on: December 04, 2011, 07:25:31 AM »
I think they were always like that, even on the first mockup i made

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #391 on: December 04, 2011, 08:26:23 AM »
OK, here's a screenshot after the changes.  Let me know if the layout is ok.  I moved the A/B buttons to 90% X, because 100% looked a little crammed.


Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline roymustang16

  • byte
  • *
  • Posts: 12
    • View Profile
Re: Alpha Testing Underway!
« Reply #392 on: December 04, 2011, 08:31:13 AM »
It's perfect, but the fps counter doesn't seem to be exactly in the middle of the screen.
Anyway, really impatient to try the next version with GUI.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #393 on: December 04, 2011, 08:35:34 AM »
The reason the FPS isn't exactly centered is the way I wrote the code - it centers the numbers on the FPS background image (so I extended some transparent space on the left side of the background image so the numbers show up in the correct place).  If it's really noticeable, I can tweak the X percentage so it looks centered (will only work for a particular aspect ratio of course).

--EDIT-- I'll just add a couple more parameters (numx and numy) which specify a percentage on the background image where the numbers should be centered.  This will solve the centering issue.
« Last Edit: December 04, 2011, 08:52:47 AM by Paul »
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline roymustang16

  • byte
  • *
  • Posts: 12
    • View Profile
Re: Alpha Testing Underway!
« Reply #394 on: December 04, 2011, 08:56:35 AM »
It's only noticeable because the start button is centered, but seriously it's doesn't matter.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #395 on: December 04, 2011, 09:28:41 AM »
No worries, it was an easy fix.  Here's how it looks now with the new number offset parameters:


Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #396 on: December 04, 2011, 10:00:52 AM »
Kris, I've been meaning to ask you, do you have the source for rsp-no-sound posted somewhere, or are you keeping that library closed at the moment?
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Kris

  • Developer
  • int
  • *****
  • Posts: 91
    • View Profile
Re: Alpha Testing Underway!
« Reply #397 on: December 04, 2011, 10:33:53 AM »
For the no-sound I just return early from a method, I just compiled it and changed it back. I checked to see if I had the change in source control but it isn't there. If I remember correctly I put either 'return 0;' or 'return -1;' at the beginning of audio_ucode in main.c:69. I originally named it libmupen64plus-rsp-hle-no-sound but that conflicted and caused the wrong library to be loaded.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #398 on: December 04, 2011, 11:05:19 AM »
Gotcha, thanks.  I haven't really looked at the code for the rsp plug-in yet (it compiled "out-of-the-box"), so I wasn't sure what all would be involved.  Sounds simple enough.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #399 on: December 04, 2011, 11:12:31 AM »
I finished adding your updates to the rice plug-in.  It's looking much better  :)
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline kane

  • byte
  • *
  • Posts: 10
    • View Profile
Re: Alpha Testing Underway!
« Reply #400 on: December 04, 2011, 11:52:58 AM »
hello guys,

i just found this site and i see you are working on this for a long time. i have a samsung galaxy ace and i want to play nintendo 64 games, n64oid doesnt work :( how far are you in ? is there already a way to download this? i?m searching for monthes and i think i finally found something here. You would make me very happy with a download link, see you soon :)

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #401 on: December 04, 2011, 11:56:47 AM »
There is a link in the initial post of this thread, however it will not work at the moment unless you manually replace the app-data after running the app the first time.  I'm in the middle of a fairly major update, so stay tuned for the next official build (hopefully today if I can finish everything)
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline kane

  • byte
  • *
  • Posts: 10
    • View Profile
Re: Alpha Testing Underway!
« Reply #402 on: December 04, 2011, 11:59:35 AM »
wow what a fast answere, didnt expect this. thank you very much. I will wait then, please tell me when your finished. I dont even have a idea about all this, so i cant do nothing by my own :). you would make me so happy if this would work on my ace.

Offline scorpio16v

  • long
  • ***
  • Posts: 203
    • View Profile
Re: Alpha Testing Underway!
« Reply #403 on: December 04, 2011, 12:22:09 PM »
[ot] zodttd tweets, that he'll release a new update for n64iphone in a few days. [/ot]

Maybe he has new sources ideas ?  ;D

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #404 on: December 04, 2011, 12:26:09 PM »
Quick update on where I'm at (for anyone interested):

I've nearly finished implementing the new virtual gamepad syntax.  The main difference, as you can see in my earlier screenshots, is the ability to add an FPS indicator (thanks, roymustang16 for the artwork - it looks great!)  I still need to add the "SDL button" option to the syntax (this will be finished shortly).  I'm not planning to add any of these to the default layouts, I just want them to be an option (to make things like "fast forward", "reset", etc possible from the virtual gamepad).

I fixed all of the bugs (that I'm aware of) with the virtual gamepad.  There is now no difference in speed between the "touch" version and the one with the stick (the problem was related to thread synchronization).  I'll still leave the "touch" skins as an option in case there is still a performance difference on slower devices.  I also added some new "tiny" layouts for super-small screens.

I've incorporated Kris' updates to the gles2rice video plug-in.  There are still some issues, including flickering shadows and stars in Mario64, inaccurate textures (grass inside the castle in Mario64), slow frame-rate (around 17-19 FPS in Mario64), and some problems with the 2D images ("Press Start" is missing in Mario64).  Overall, though, it is looking very good (Conkers is rendered nearly perfect - just a few sorting errors).

I've compiled Kris' no-sound RSP plug-in idea.  It provides a noticeable improvement to higher-end games (Zelda64 runs full-speed in the forest with all the flying fairies even without overclocking, Conkers is more playable, etc.)

I'm still having some issues with the menu switching logic (resulting in occasional crashes or ending up in the wrong area).  This is the main thing I need to sort out before I post the next update.  There are also two or three options in the menu that don't function yet (I mentioned them earlier in this thread).
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted