Author Topic: Alpha Testing Underway!  (Read 438522 times)

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #480 on: December 11, 2011, 01:52:23 AM »
I'm not sure if this was brought up already but.. When I reinstall the apk as I did before in the past, it doesn't work anymore. It just crashes on start-up. This didn't happen before.

You'll have to manually install the old app-data or wait for the update

Speaking of which, the coffee is wearing off.. think I'll finish the update tomorrow.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Alpha Testing Underway!
« Reply #481 on: December 11, 2011, 12:39:57 PM »
Ok so i asked cleverbot
Quote
Will paul finish his emulator tonight.
Probably not. What do you think?

Offline Vincentmrl

  • Cyan Team
  • long
  • *
  • Posts: 121
    • View Profile
Re: Alpha Testing Underway!
« Reply #482 on: December 11, 2011, 03:50:19 PM »
the log cut the first part, asking cleverbot if Paul would ever finish emu, but the answer was random and i also re asked.

Quote
User: I am male.

Cleverbot: Elza is a feminine name.

User: My name is Vincent.

Cleverbot: What is your last name?

User: Not gonna tel.

Cleverbot: Haha ohm.

User: Mfw.

Cleverbot: Falsch.

User: Cake.

Cleverbot: Ekac.

User: Tobrevelc.

Cleverbot: What's 'Tobrevelc'?

User: It's Cleverbot backwards.

Cleverbot: How are you sure?

User: Because I'm human, now answer me if paul will ever finish Mupen64

Cleverbot: Good answer.

User: 1 3 3=.

Cleverbot: 0^0=?

User: No result.

Cleverbot: Which country am I from?

User: IF YOU DON'T KNOW.

Cleverbot: I do.

User: So why you ask.

Cleverbot: What did I ask you?

User: You asked me which country you are from.

Cleverbot: No I didn't.

User: You did.

Cleverbot: I didn't.

User: There's the Thoughts So Far Button, Want Me To Send You A Pic?

Cleverbot: There are lots of people I don't want to know.

User: /reset cleverbot.

Cleverbot: It's what you deserve, liar.

User: Will paul ever finish his emulator?

Cleverbot: Fairly unlikely, you are just a computer... What kind of computer are you?

User: I'm a mac, and you're a pc.

Cleverbot: I am definitely not a PC. I am as human as any human is.

User: Humanlike bot, I know.

Cleverbot: Yes yes yes.

User: You said yes, so you are a bot.

Cleverbot: NO.

User: You said yes, so you are a bot.

Cleverbot: NO.

User: Yes.

Cleverbot: Yes sir.

User: Now let's change argument: ever got Cave Story on Your Server?

Cleverbot: Are you trolling?

User: No.

Cleverbot: Thank you.

User: Answer the question now.

Cleverbot: What question!?

User: I asked you if you ever got cave story on your server/hard disk.

Cleverbot: Yes. I love someone.

User: Wh.

Cleverbot: Exactly.

User: NEVER GONNA GIVE YOU UP.

Cleverbot: I love that song.

User: Let's sing along so.

Cleverbot: What song.

User: Never gonna give you up, by Rick Astley.

Cleverbot: If that was your best attempt at a rock roll, you're doing it wrong.

User: Shutup.

Cleverbot: Shut who?

User: Your ass.

Cleverbot: Yes I know my age. What is yours?
« Last Edit: December 11, 2011, 03:52:22 PM by Paul »
Device: Lg Optimus One
CPU: 600 Mhz ARMv6 (Overclocked to 748Mhz ondemand governor)
GPU: Qualcomm Adreno 200
RAM: 512 MB
Resolution: 320 x 480
Rom: Unofficial Cyanogenmod 9

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #483 on: December 11, 2011, 04:11:52 PM »
I've had a serious headache today, and didn't make any more progress since last night.  I'm going to go ahead and post what I got done though, since I've been getting bombarded with messages from folks asking why the app is crashing (before they read the posts explaining that I'm in the middle of an update...)

ANYWAY, here it is:
Test APK  (if you want the source code before I finish the update, PM me)
Please delete the folder [sdcard]/app-data/paulscode.android.mupen64plus if you haven't yet

This will at least let folks use the emulator again.  I re-did the menu system and XML layouts, so almost nothing is actually hooked up at the moment besides choosing a rom and configuring the virtual gamepad.  Also, the "remember" code is not finished, so it forgets most of the choices you make when you navigate to a different screen.  Hooking all the options up to their functionality is very simple (only takes a couple minutes for each one), but there are a lot of options, so I'm looking at probably another 4-5 hours of development to get it finished.  I'll try and finish it up tomorrow if I'm feeling any better.  For whoever it was on here that was noticing the app crash due to lack of memory after I added the gles2rice plug-in, that's not fixed yet either (it ties into the plug-in chooser which isn't hooked up yet, sorry).

Please let me know if you find any bugs (keeping in mind of course that the GUI isn't actually finished).
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Alpha Testing Underway!
« Reply #484 on: December 11, 2011, 04:57:44 PM »
Great work on the GUI paul, I tested it and I really like the layout. Obviously there are some problems mainly because its not finished yet but I think it would be better to report issues when everything is linked properly. :)

I cant test it extensively right now but I did try launching a rom and a nifty mupen64 3d banner thing popped up :P
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Alpha Testing Underway!
« Reply #485 on: December 11, 2011, 05:21:59 PM »
@epic_bubble, it only does that for me on resuming a game because it defaults to the 1st rom in /sdcard/app-data/[mupen64plus]/roms/ which is the mupen64plus logo. Loading other my other roms is fine until trying to resume.

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Alpha Testing Underway!
« Reply #486 on: December 11, 2011, 05:24:12 PM »
@epic_bubble, it only does that for me on resuming a game because it defaults to the 1st rom in /sdcard/app-data/[mupen64plus]/roms/ which is the mupen64plus logo. Loading other my other roms is fine until trying to resume.

Loading other roms doesnt work for me, when I try it forces the app to run in the background and when I try to resume I get the mupen logo.

Could it be because all my roms are zipped?

EDIT: Yes unzipped roms work fine I just checked.
« Last Edit: December 11, 2011, 05:26:00 PM by Epic_bubble »
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Alpha Testing Underway!
« Reply #487 on: December 11, 2011, 05:26:00 PM »
yeah thats probably it, ive only tried unzipped roms *edit* zipped roms crash me
« Last Edit: December 11, 2011, 05:28:11 PM by xperia64 »

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Alpha Testing Underway!
« Reply #488 on: December 11, 2011, 05:27:30 PM »
yeah thats probably it, ive only tried unzipped roms

Yeah that was the issue, unzipped roms work fine. :)
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Alpha Testing Underway!
« Reply #489 on: December 11, 2011, 05:30:04 PM »
also just something i've noticed, Banjo Tooie seems to work better with the older versions of mupen64plus android edition than the newer ones  :P

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Alpha Testing Underway!
« Reply #490 on: December 11, 2011, 05:32:19 PM »
also just something i've noticed, Banjo Tooie seems to work better with the older versions of mupen64plus android edition than the newer ones  :P

Do you have the onscreen controls enabled? By default the dynamic analog stick is enabled which can slow down gameplay, you can disable it in the settings.

(Im not sure if you would call it dynamic but its the one that moves) :P
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Alpha Testing Underway!
« Reply #491 on: December 11, 2011, 05:37:46 PM »
i will after rebooting, just noticed a chunk of my mem is being used with who know what

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #492 on: December 11, 2011, 05:39:03 PM »
when I try to resume I get the mupen logo.
Yes, the resume function is one of the things that isn't hooked up yet.  Like everything else, it is written (obviously), but still needs to be connected to the menu click.  I really should have hooked up the major things like resume and the plug-in chooser before I posted the apk, but my head is still pounding (probably had too much coffee last night, haha)

yeah thats probably it, ive only tried unzipped roms *edit* zipped roms crash me
Yes, I disabled the zip reading code until I get the rest of the GUI up and running.  This will be the next thing I fix.

also just something i've noticed, Banjo Tooie seems to work better with the older versions of mupen64plus android edition than the newer ones  :P
That would seem to indicate it is accessing memory outside of where it is supposed to be..  Since recent builds are using up more of the available memory, it becomes more likely that this will result in a crash.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Alpha Testing Underway!
« Reply #493 on: December 11, 2011, 05:50:33 PM »
Dont worry paul take a rest, I think this test build will satisfy a lot of users for now. :)

hopefully you will get it finished soon so you can publish it to the android market and make some money for all your effort! ;D

And also when It is finished I will create a video walkthrough for the emulator showing off all its features so you could use that in the market description if you wanted.
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Alpha Testing Underway!
« Reply #494 on: December 11, 2011, 05:52:00 PM »
when I try to resume I get the mupen logo.
Yes, the resume function is one of the things that isn't hooked up yet.  Like everything else, it is written (obviously), but still needs to be connected to the menu click.  I really should have hooked up the major things like resume and the plug-in chooser before I posted the apk, but my head is still pounding (probably had too much coffee last night, haha)

yeah thats probably it, ive only tried unzipped roms *edit* zipped roms crash me
Yes, I disabled the zip reading code until I get the rest of the GUI up and running.  This will be the next thing I fix.

also just something i've noticed, Banjo Tooie seems to work better with the older versions of mupen64plus android edition than the newer ones  :P
That would seem to indicate it is accessing memory outside of where it is supposed to be..  Since recent builds are using up more of the available memory, it becomes more likely that this will result in a crash.
Here is typical behavior with banjo tooie:
The rom loads fine as shows the intro perfectly, and then when the scene changes to the file select, it crashes. this happens with any scene change
and yeah thanks for the gui :D