Author Topic: Alpha Testing Underway!  (Read 431079 times)

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Alpha Testing Underway!
« Reply #495 on: December 11, 2011, 05:59:41 PM »
Yay I can see my volume button idea was added. :)


Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #496 on: December 11, 2011, 07:12:57 PM »
Yay I can see my volume button idea was added. :)
It is a great, simple idea.  This is one of the few things that's actually hooked up right now, BTW (although it still "forgets" what you picked once you leave the game activity or close the app).  I think I'll leave this setup in place.. the other way would probably just end up confusing people.

hopefully you will get it finished soon so you can publish it to the android market and make some money for all your effort! ;D
Yes, I'm hoping to sell enough copies to afford some various hardware to help with the project.  In particular, I'd like to get my hands on a variety of joysticks.  I'd also like to get a Pandora once they start production on them again, so I can more easily develop a patch for the official Mupen64Plus project that adds support for Android and Pandora.  And not to be greedy, but an XPeria Play would be nice too  ;D
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Alpha Testing Underway!
« Reply #497 on: December 11, 2011, 07:25:41 PM »
Xperia Plays are relatively cheap depending on what model you want  (especially compared to pandoras) ;D
« Last Edit: December 11, 2011, 07:27:42 PM by xperia64 »

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Alpha Testing Underway!
« Reply #498 on: December 11, 2011, 08:00:29 PM »
Hey Paul I found this and it looked like something you might be interested in, a guy has put a video up on YouTube showing how to create a NES emulator from scratch in half an hour! There are never usually videos about emulator development and it's crazy to see him code it that fast.

http://www.youtube.com/watch?v=y71lli8MS8s
« Last Edit: December 11, 2011, 08:16:04 PM by Epic_bubble »
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #499 on: December 11, 2011, 08:06:12 PM »
Haha, wow..  There's somebody with way too much time on his hands.  Even though it is sped up, he still would have needed to spend months memorizing every line of code to be able to pull off a video like that (or maybe he has a photographic memory).

-- On second thought, he probably did that with a keystroke recorder.  Still impressive, though - he makes very few mistakes.
« Last Edit: December 11, 2011, 08:11:26 PM by Paul »
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline scorpio16v

  • long
  • ***
  • Posts: 203
    • View Profile
Re: Alpha Testing Underway!
« Reply #500 on: December 12, 2011, 05:25:52 AM »
The rice plugin works much better. still some bugs, but some things are fixed now. the gui looks good.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #501 on: December 12, 2011, 06:10:49 AM »
This is the coolest thing I've seen in a while...


(source code)
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline neo3

  • byte
  • *
  • Posts: 11
    • View Profile
Re: Alpha Testing Underway!
« Reply #502 on: December 12, 2011, 08:13:38 AM »
Hi Paul,

I see that your emulator is getting very good, congratulations for the work!

I tested now in my Galaxy Ace with Gingerbread 2.3.4, and is running reasonably, I wanted to disable the audio to see if the game speed increases, but this makes me more anxious to see the stable version.

I found a strange thing, at the beginning of the Zelda, when he goes out of his house that shows a top view, the house appears green without the textures of the wood of the house.

And one suggestion I wanted to give, if you can increase the size of the display of the FPS of the gamepad small, because here in my Galaxy Ace i can't see the number of frames right.

Congratulations again at work!

Offline Mats

  • int
  • **
  • Posts: 65
    • View Profile
Re: Alpha Testing Underway!
« Reply #503 on: December 12, 2011, 08:39:28 AM »
The gui is looking good but when i try to load a rom it crash and the app ends is this becuse it unstable ??? i have a xperia x8.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Alpha Testing Underway!
« Reply #504 on: December 12, 2011, 08:54:55 AM »
The gui is looking good but when i try to load a rom it crash and the app ends is this becuse it unstable ??? i have a xperia x8.

Looks like you were the one I was talking about...

all the builds before the package got 2 mb works and the last build that work is : ARM6, VFP Test

For whoever it was on here that was noticing the app crash due to lack of memory after I added the gles2rice plug-in, that's not fixed yet either (it ties into the plug-in chooser which isn't hooked up yet, sorry).
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Alpha Testing Underway!
« Reply #505 on: December 12, 2011, 10:10:20 AM »
That vnes emulator is pretty amazing! this is even cooler though, its a GBC emulator made in HTML5 (and probably some other stuff too). I can run it on my iPad without needing to jailbreak (since its all html5) but it runs super slow. Work fine on my desktop though.

Link: http://www.grantgalitz.org/gameboy/
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline maciek9971

  • bit
  • Posts: 8
    • View Profile
Re: Alpha Testing Underway!
« Reply #506 on: December 12, 2011, 10:15:28 AM »
Hello Paul,

In latest Test App when i have to open rom, emulator is always closing before running a game. I have Xperia x10 mini pro and i dont know what should i do. Help :P

Sorry for my bad english.  ;)

Offline mas

  • bit
  • Posts: 1
    • View Profile
Re: Alpha Testing Underway!
« Reply #507 on: December 12, 2011, 11:03:35 AM »
Hey Paul,

    First, let me say that I'm enthralled that N64 has been brought to Android. I am running your emulator on the original Droid. The emulator is working fine, but I was wondering if there was a way to boost the frame rate on this. Was this device meant to run the emulator smoothly? Please let me know your thoughts.

With much appreciation,
                        Michael S.

Offline TFreestone

  • Cyan Team
  • byte
  • *
  • Posts: 31
    • View Profile
    • AtshruDev Coding Blog
Re: Alpha Testing Underway!
« Reply #508 on: December 12, 2011, 11:45:10 AM »
I found a strange thing, at the beginning of the Zelda, when he goes out of his house that shows a top view, the house appears green without the textures of the wood of the house.
i noticed that too. It has to do with a bug in the default plugin in rendering 2d textures, such as link's house and the entrances to the Castle Market and Temple of Time. It may or may not be fixed in a later update to the plugin.

@Paul - This particular thread is the Testing/discussion thread correct? Might i suggest making separate threads for Bug reports, tesing, etc. and then another one for QandA / Support as well as maybe a sickie for people who are new to the project and need to learn the basics, to avoid every new person asking the same questions and so on.

@Everyone - Check back a few pages (or all of them ;) ) and make sure your question hasn't already been answered.
My twitter: https://twitter.com/T0umas9
My Phone: Google Nexus 4 Paranoid Android 4.3b1 KK (4.4.2)
Chip: Qualcomm APQ8064 Snapdragon
CPU: Quad-core 1.5 GHz Krait
GPU:   Adreno 320
RAM: 2Gb
Accelerometer, gyro
768 x 1280 pixels, 4.7 inches (~318 ppi pixel density)

Offline kane

  • byte
  • *
  • Posts: 10
    • View Profile
Re: Alpha Testing Underway!
« Reply #509 on: December 12, 2011, 12:52:57 PM »
thank you very much, the emulator works. you really did a good job, but i have got a question. the fps is very low (around 9-12), and the video + audio is laggy. is there a way to change that?