Author Topic: 3D Sound System looping  (Read 9074 times)

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3495
  • Developer
    • View Profile
    • PaulsCode.Com
Re: 3D Sound System looping
« Reply #15 on: December 20, 2011, 01:54:39 PM »
Sorry, I haven't been able to pinpoint the problem.  It seems to be related to the albuffer queuing and dequeuing, but I can't figure out why it only happens between the loops and not between queued samples.  I'll look at this some more tomorrow, hopefully I can figure out what's going wrong.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline floyd

  • byte
  • *
  • Posts: 10
    • View Profile
Re: 3D Sound System looping
« Reply #16 on: January 06, 2012, 06:00:15 AM »
Hi!

I just wanted to know if there is a chance this will work soon... Don't want to bother you, really, but I want to finish a project using this library.

Problem is, I can't take it this way with the defect looping, so I have to search for an alternative then.

Or can you offer some workaround around this issue?

Thanks!
« Last Edit: January 06, 2012, 10:18:26 AM by floyd »

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3495
  • Developer
    • View Profile
    • PaulsCode.Com
Re: 3D Sound System looping
« Reply #17 on: January 06, 2012, 02:09:53 PM »
Sorry, man, I'll fix this tomorrow for you.  I've been obsessed with my main project and forgot all about it this week.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3495
  • Developer
    • View Profile
    • PaulsCode.Com
Re: 3D Sound System looping
« Reply #18 on: January 07, 2012, 03:06:34 PM »
I found the problem (finally!)  It was a logic error in the code, and was actually in the core SoundSystem library, not the plug-ins (even though that's where the problem manifested itself).  I haven't done a lot of testing after the changes, so be sure to let me know if any new problems have popped up.  I posted the link in the General->Paul's Projects section.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline floyd

  • byte
  • *
  • Posts: 10
    • View Profile
Re: 3D Sound System looping
« Reply #19 on: January 08, 2012, 12:05:26 PM »
It's working for me now... Thank you very much!
Your library is the only one fitting my needs...

I'll post a link to the project when its done...