Author Topic: Legend of Zelda-Ocarina of Time  (Read 1097 times)

Offline Clay87

  • bit
  • Posts: 1
    • View Profile
Legend of Zelda-Ocarina of Time
« on: July 29, 2016, 12:08:06 AM »
Hello,
So I am very new to the forum, I apologize if this question was already asked. Ok, when I go to play Zelda-Ocarina of Time, the button for Attack says A, and it is also the Jump button (so I can not attack). Is there a way to configure the controller buttons differently through mupen, or is the problem lie within the game?
I have a nightly build of Mupen64plus v3.a.0 on my nvidia shield tv console. Everything is working great. I have it set to GlideN64-GLES-3.1. I set shield as my default controller, I have even used xbox 360 wireless controllers (in multiplayer) with my OTG adapter.
I'm fairly new to emulating (since my n64 would no longer keep up with my newer televisions frame rate, I did a google search and discovered emulators lol. I am trying to put my gf's favorite game on the shield tv console, and it has been very frustating, any suggestions or help would be much appreciated).
Cheers, Clay
« Last Edit: July 29, 2016, 12:10:22 AM by Clay87 »

Offline fzurita

  • Moderator
  • double
  • *****
  • Posts: 558
    • View Profile
Re: Legend of Zelda-Ocarina of Time
« Reply #1 on: July 29, 2016, 01:01:34 AM »
For the Shield TV you have to create a custom controller profile. To do that:
1. Open up the side bar menu in the gallery
2. Go to controller profiles
3. On the top right menu select "New"
4. Give the profile a name
5. For each N64 button, you have to push A to assign it a Shield controller button.
   - If you want to unbind a button, hold A
   - I would highly recommend you assign a Shield controller button to the menu option
6. Hit the B button to back out of your new controller profile.
7. Highlight the new controller profile and select "Set default"