Author Topic: Beta Testing Has Begun!  (Read 824981 times)

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3496
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #255 on: March 05, 2012, 02:42:49 PM »
everytime i go to open a rom it goes to the screen with the buttons on the screen, but its all black, and then just kicks me out to my homescreen. my roms are in a .v64 file type. anyone have any suggestions?

Please test with Mario 64 if you own it.  Also, let me know what device you are running the app on.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline iThi3f

  • bit
  • Posts: 7
    • View Profile
Re: Beta Testing Has Begun!
« Reply #256 on: March 05, 2012, 02:59:36 PM »
thats the game that ive been trying to play, Mario 64. I'm using an HTC EVO.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3496
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #257 on: March 05, 2012, 03:05:23 PM »
That phone has decent specs, so it should be able to handle the app.  Please try enabling/ disabling Tribuffer Opt in Settings->Video->Configure.  Also try changing the plugin to gles2rice to see if it works.  If neither of those work, let me know, and I'll write a verbose test for you to run to try and track down the problem.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline iThi3f

  • bit
  • Posts: 7
    • View Profile
Re: Beta Testing Has Begun!
« Reply #258 on: March 05, 2012, 04:48:57 PM »
i tried those suggestions and im still getting the same problem. just kicks me back out to my home screen everytime. it goes to the screen where it looks like its about to start with the buttons on the screen but just all black.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3496
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #259 on: March 05, 2012, 04:53:40 PM »
Could you post a logcat after the problem occurs?  If you aren't familiar with accessing the logs, I posted instructions here.  The log probably won't have anything useful, but I'll give that a look before I do a debug build.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline iThi3f

  • bit
  • Posts: 7
    • View Profile
Re: Beta Testing Has Begun!
« Reply #260 on: March 05, 2012, 06:07:08 PM »
Alright i followed the instructions and assuming i did it right. Will I have to access that saved text file through my computer to post on here?

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3496
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #261 on: March 05, 2012, 06:30:14 PM »
Maybe.  You might be able to attach it from the Android browser if you want to do it from your phone (I haven't tried this before)
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline iThi3f

  • bit
  • Posts: 7
    • View Profile
Re: Beta Testing Has Begun!
« Reply #262 on: March 05, 2012, 06:45:16 PM »
Ok so it looks like i cant do it from my phone, ill have to wait to post the logcat til i get home.

Offline iThi3f

  • bit
  • Posts: 7
    • View Profile
Re: Beta Testing Has Begun!
« Reply #263 on: March 06, 2012, 02:51:58 AM »

D/dalvikvm(20292): Trying to load lib /mnt/asec/paulscode.android.mupen64plus-1/lib/libinput-sdl.so 0x4051daa8
D/dalvikvm(20292): Added shared lib /mnt/asec/paulscode.android.mupen64plus-1/lib/libinput-sdl.so 0x4051daa8
D/dalvikvm(20292): No JNI_OnLoad found in /mnt/asec/paulscode.android.mupen64plus-1/lib/libinput-sdl.so 0x4051daa8, skipping init
D/dalvikvm(20292): Trying to load lib /mnt/asec/paulscode.android.mupen64plus-1/lib/librsp-hle.so 0x4051daa8
D/dalvikvm(20292): Added shared lib /mnt/asec/paulscode.android.mupen64plus-1/lib/librsp-hle.so 0x4051daa8
D/dalvikvm(20292): No JNI_OnLoad found in /mnt/asec/paulscode.android.mupen64plus-1/lib/librsp-hle.so 0x4051daa8, skipping init
V/SDLActivity.java(20292): CPU info available from file /proc/cpuinfo:
V/SDLActivity.java(20292): Processor   : ARMv7 Processor rev 2 (v7l)
V/SDLActivity.java(20292): BogoMIPS   : 662.40
V/SDLActivity.java(20292): Features   : swp half thumb fastmult vfp edsp thumbee neon vfpv3
V/SDLActivity.java(20292): CPU implementer   : 0x51
V/SDLActivity.java(20292): CPU architecture: 7
V/SDLActivity.java(20292): CPU variant   : 0x0
V/SDLActivity.java(20292): CPU part   : 0x00f
V/SDLActivity.java(20292): CPU revision   : 2
V/SDLActivity.java(20292):
V/SDLActivity.java(20292): Hardware   : supersonic
V/SDLActivity.java(20292): Revision   : 0004
V/SDLActivity.java(20292): Serial      : 0000000000000000
V/SDLActivity.java(20292): ���������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������
D/dalvikvm(20292): GC_EXTERNAL_ALLOC freed 176K, 42% free 3307K/5639K, external 650K/662K, paused 55ms
D/dalvikvm(20292): GC_EXTERNAL_ALLOC freed 74K, 41% free 3343K/5639K, external 1107K/1178K, paused 50ms
D/dalvikvm(20292): GC_EXTERNAL_ALLOC freed 7K, 41% free 3346K/5639K, external 1805K/1815K, paused 34ms
D/SensorGUI(  116): SensorChannel(): mSendFd = 256, mReceiveFd = 253
D/SensorGUI(20292): SensorChannel(const Parcel& data): mSendFd = -1, mReceiveFd = 50
D/SensorService(  116): enable: connection.get() = 0x10c7e08, (2.3.3-1)
D/SensorService(  116): enable: get sensor name = BMA150 3-axis Accelerometer
D/SensorService(  116): SensorDevice::activate: handle = 0x0, enabled = 0x1
D/Sensors (  116): Enable akm: en = 1
D/SensorService(  116): noteStartSensor: uid = 0x275c, handle = 0x0
D/SensorService(  116): pid=20292, uid=10076
D/SensorService(  116): Active sensors:
D/SensorService(  116): BMA150 3-axis Accelerometer (handle=0x00000000, connections=2)
D/SensorService(  116): CM3602 Light sensor (handle=0x00000004, connections=1)
V/SDLSurface(20292): SDLSurface changed
I/SDL     (20292): SDL_Android_Init()
V/front_end(20292):  __  __                         __   _  _   ____  _             
V/front_end(20292): |  \/  |_   _ _ __   ___ _ __  / /_ | || | |  _ \| |_   _ ___
V/front_end(20292): | |\/| | | | | '_ \ / _ \ '_ \| '_ \| || |_| |_) | | | | / __| 
V/front_end(20292): | |  | | |_| | |_) |  __/ | | | (_) |__   _|  __/| | |_| \__ \ 
V/front_end(20292): |_|  |_|\__,_| .__/ \___|_| |_|\___/   |_| |_|   |_|\__,_|___/ 
V/front_end(20292):              |_|         http://code.google.com/p/mupen64plus/ [nofollow] 
V/front_end(20292): Mupen64Plus Console User-Interface Version 1.99.4
V/front_end(20292):
V/core_interface(20292): UI-console: attached to core library 'Mupen64Plus Core' version 1.99.4
V/core_interface(20292):             Includes support for Dynamic Recompiler.
I/ActivityManager(  116): Displayed paulscode.android.mupen64plus/.SDLActivity: +893ms
E/front-end(20292): Core Error: open_rom(): not a valid ROM image
E/front-end(20292): Error: core failed to open ROM image file '/mnt/sdcard/n64 rom/Super Mario 64.v64'.
D/skia    ( 9541): purging 304K from font cache [36 entries]
D/SensorService(  116): SensorDevice::activate: handle = 0x0, enabled = 0x0
D/SensorGUI(  116): ~SensorChannel: mSendFd = 256, mReceiveFd = -1
I/ActivityManager(  116): Process paulscode.android.mupen64plus (pid 20292) has died.
I/WindowManager(  116): WIN DEATH: Window{40c26fe8 paulscode.android.mupen64plus/paulscode.android.mupen64plus.SDLActivity paused=false}

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3496
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #264 on: March 06, 2012, 05:02:45 AM »
It looks like there is a problem with your ROM:

Code: [Select]
E/front-end(20292): Core Error: open_rom(): not a valid ROM image
E/front-end(20292): Error: core failed to open ROM image file '/mnt/sdcard/n64 rom/Super Mario 64.v64'

I recommend you rip it again (or get it from another source).  If you have an N64 emulator installed on your PC, I find that to be a good way to test ROMs to see if they are ok, or if there is a bug in the app.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline iThi3f

  • bit
  • Posts: 7
    • View Profile
Re: Beta Testing Has Begun!
« Reply #265 on: March 06, 2012, 12:38:48 PM »
that fixed it, its running now. thanks! is there anyway to not make it so laggy though?

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3496
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #266 on: March 06, 2012, 03:16:07 PM »
I posted some tweaks to try in this thread.  You could also try using gles2rice which is a lot faster now on some devices with SkipFrame enabled.  Another thing you could try is the Xperia Play branch instead of the main one (it has a slightly different build of gles2n64 which runs a tad faster on a few devices).  I will be working to optimize the app moving forward, but currently there really aren't a lot of things to make it run faster.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline cuttler

  • bit
  • Posts: 7
    • View Profile
Re: Beta Testing Has Begun!
« Reply #267 on: March 08, 2012, 10:26:19 AM »
Hey Paul,  you think you could add in a key pad that has the joystick and dpad together? Some games require both.

Offline xperia64

  • Moderator
  • double
  • *****
  • Posts: 591
    • View Profile
    • My Apps
Re: Beta Testing Has Begun!
« Reply #268 on: March 08, 2012, 01:44:45 PM »
This thread has some nice gamepads with both: http://www.paulscode.com/forum/index.php?topic=221.0

Offline lolzDRAGON97

  • bit
  • Posts: 3
    • View Profile
Re: Beta Testing Has Begun!
« Reply #269 on: March 09, 2012, 04:40:14 PM »
Anybody have a fix for the galaxy ace lagg?