Author Topic: Beta Testing Has Begun!  (Read 959159 times)

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #105 on: January 17, 2012, 11:28:28 PM »
I uploaded the v1.4 update today (see the first post in this thread for details).

There were some fairly extensive changes in the GUI, so if anyone runs into problems, please let me know, so I can fix them right away.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline tofi1106

  • byte
  • *
  • Posts: 12
    • View Profile
Re: Beta Testing Has Begun!
« Reply #106 on: January 18, 2012, 01:39:07 PM »
thank you paul! :D it look pretty good!, emulation is more faster than 1.3 but I?ve seen a bug, when I disable auto frame skip, mario 64 crashes,  in fact just shows a white screen after the face presentation "press start to play", it still emulating the sound but video is freeze, but it happens only in this game, because I've tried another games like super smash bros and they haven't problem with this, why you've removed "resume" option??? and like a suggestion I think it would be great if you could add minimize support, it would be possible?

edit: I have tried with mario kart 64 and it have a similar bug, in this game the screen gets stuck but it happens only when I put the max frameskip in 3 or 4 or 5
« Last Edit: January 18, 2012, 01:53:34 PM by tofi1106 »

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #107 on: January 18, 2012, 01:56:01 PM »
Did v1.3 or earlier crash Mario64 when auto frameskip was disabled (or did you have a chance to test it prior to 1.4?)  Just want to figure out if this is something new with version 1.4, or if it has been around a while.

The "Resume" option was not removed, it only appears in the menu if there is a session saved that it can resume (to prevent crashes and confusion from folks who don't have any idea what it is for).  Enable "Auto Save" if it is disabled, then from the in-game menu choose either "Close" or "Menu", or press "Home".  Then the "Resume" option will reappear in the menu, because there will be a game session saved.  If it doesn't reappear, let me know (that would be a bug).

Minimize support will be added after I fix the other bug I mentioned with the SDL Surface.  This is on my list of things to do.  I'll probably put this off until I remove the SDL linkage (coming soon)
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline tofi1106

  • byte
  • *
  • Posts: 12
    • View Profile
Re: Beta Testing Has Begun!
« Reply #108 on: January 19, 2012, 05:40:29 AM »
heey paul!, well, I've tried in Mupen64plus 1.2, 1.3 and last version disabling auto frameskip and here are the results:

1.2: In this version game starts ok, but when I enter to the castle screen turns black, the sound still emulating and  I can hear mario steps if I use the analog stick, but screen not shows nothing.

1.3: In this version game screen freezes when I push start on the face presentation screen (screen turns white)

1.4: In this version occurs the same thing than 1.3 version

Well... I want to tell you something else, in 1.4 version resume option never shows, I've played mario kart, mario 64, star fox and all star tennis 99, I have the "auto save"  option enabled, I saved all the games even quick save in 0 slot, but option still without appear
« Last Edit: January 19, 2012, 05:45:39 AM by tofi1106 »

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Beta Testing Has Begun!
« Reply #109 on: January 19, 2012, 06:57:19 AM »
I think implementing some sort of FAQ into the emulator would be a good idea, even if its just a button that links to the FAQ here it might help lower the amount of questions and confusion.

Maybe a message that appears the first time the app is launched which could have some important information might be a better idea.

Im just trying to think whats the best way to help new users since a lot of people using mupen have never used emulators before so they dont even understand what the term ROM means.
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #110 on: January 19, 2012, 07:04:50 AM »
heey paul!, well, I've tried in Mupen64plus 1.2, 1.3 and last version disabling auto frameskip and here are the results:

1.2: In this version game starts ok, but when I enter to the castle screen turns black, the sound still emulating and  I can hear mario steps if I use the analog stick, but screen not shows nothing.

1.3: In this version game screen freezes when I push start on the face presentation screen (screen turns white)

1.4: In this version occurs the same thing than 1.3 version

Well... I want to tell you something else, in 1.4 version resume option never shows, I've played mario kart, mario 64, star fox and all star tennis 99, I have the "auto save"  option enabled, I saved all the games even quick save in 0 slot, but option still without appear

Thanks, I'll look into the Auto Save/ Resume problem (could be a logic error that I overlooked).  For your other problem with the screen turning white and freezing, let me write a test for you to run.  This is on the Optimus One (cyanogenmod 7.2) overclocked to 768mhz?  (or a different device?)
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline tofi1106

  • byte
  • *
  • Posts: 12
    • View Profile
Re: Beta Testing Has Begun!
« Reply #111 on: January 19, 2012, 01:04:20 PM »
Yep! I've tried in my optimus p500 cyanogenmod 7.2 overclocked to 729mhz And in a optimus p350 rom stock froyo 2.2.2 V10A TELCEL MEXICO overclocked to 768mhz and occurs the same issue on both devices
« Last Edit: January 19, 2012, 01:10:07 PM by tofi1106 »

Offline Chaim

  • bit
  • Posts: 2
    • View Profile
Re: Beta Testing Has Begun!
« Reply #112 on: January 19, 2012, 01:28:01 PM »
Just made the same thing(only tested in 1.4) and everything worked fine.(btw i have a lg optimus one running unnoficial cyanogenmod port overclocked to 729 mhz).
Device:LG P500
Cpu:Qualcomm MSM7227 ARM1136EJ-S
*Clock:480-729mhz(overclocked)
*Features:armv6-compatible processor rev5 (v6l), swp - half - thumb - fastmult - vfp -edsp - java
Resolution:320x480 - 180ppi
Gpu:Qualcomm Adreno 200
Extra:using a kernel that don't has touch screen lag (100%of cpu usage)

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #113 on: January 19, 2012, 03:09:12 PM »
Yep! I've tried in my optimus p500 cyanogenmod 7.2 overclocked to 729mhz And in a optimus p350 rom stock froyo 2.2.2 V10A TELCEL MEXICO overclocked to 768mhz and occurs the same issue on both devices

Could you run a couple check for me (to maybe zero in on the problem a little closer).

1) Try with Auto Frameskip enabled and Max Frameskip set at 2 (if that's not already the setting you have it on)
2) Try with Auto Frameskip disabled and Max Frameskip set at 0
3) Try with gles2rice instead of gles2n64 to see if it freezes at the same place
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Epic_bubble

  • long
  • ***
  • Posts: 235
    • View Profile
Re: Beta Testing Has Begun!
« Reply #114 on: January 19, 2012, 07:34:42 PM »
[N64oid gles2n64 game specific fixes list]


#rom specific settings

rom name=SUPER MARIO 64
target FPS=25

rom name=Kirby64
target FPS=25

rom name=Banjo-Kazooie
framebuffer enable=1
update mode=4
target FPS=25

rom name=BANJO TOOIE
hack banjo tooie=1
ignore offscreen rendering=1
framebuffer enable=1
update mode=4

rom name=STARFOX64
window width=864
window height=520
target FPS=27

rom name=MARIOKART64
target FPS=27

rom name=THE LEGEND OF ZELDA
texture use IA=0
hack zelda=1
target FPS=17

rom name=ZELDA MAJORA'S MASK
texture use IA=0
hack zelda=1

rom name=F-ZERO X
window width=864
window height=520
target FPS=55

rom name=WAVE RACE 64
window width=864
window height=520
target FPS=27

rom name=SMASH BROTHERS
framebuffer enable=1
window width=864
window height=520
target FPS=27

rom name=1080 SNOWBOARDING
update mode=2
target FPS=27

rom name=PAPER MARIO
update mode=4

rom name=STAR WARS EP1 RACER
video force=1
video width=320
video height=480

rom name=JET FORCE GEMINI
framebuffer enable=1
update mode=2
ignore offscreen rendering=1
target FPS=27

rom name=RIDGE RACER 64
window width=864
window height=520
target FPS=27

rom name=Diddy Kong Racing
target FPS=27

rom name=MarioParty
update mode=4

rom name=MarioParty3
update mode=4

rom name=Beetle Adventure Rac
window width=864
window height=520
target FPS=27

rom name=EARTHWORM JIM 3D
rom name=LEGORacers

rom name=GOEMONS GREAT ADV
window width=864
window height=520

rom name=Buck Bumble
window width=864
window height=520

rom name=BOMBERMAN64U2
window width=864
window height=520

rom name=ROCKETROBOTONWHEELS
window width=864
window height=520

rom name=GOLDENEYE
force screen clear=1
framebuffer enable=1
window width=864
window height=520
target FPS=25

rom name=Mega Man 64
framebuffer enable=1
target FPS=25
Device: Xperia play
CPU: Qualcomm 1 GHz Scorpion (Snapdragon)
GPU: Adreno 205
RAM: 512 MB
Screen res: 854 ? 480
ROM: stock android 2.3.4 rooted

Offline scorpio16v

  • long
  • ***
  • Posts: 203
    • View Profile
Re: Beta Testing Has Begun!
« Reply #115 on: January 20, 2012, 09:26:37 AM »
Isn't that the same list that came with mupen64+ae, as gles2n64rom.conf ?
I thought if a known game is recognized, this settings were allready set and overwrites the defaults in gles2n64.conf ?

I've tested config files from n64oid and the maemo and pandora port on some ROMs, but always the same results.
Is it possible, that some options like "enable framebuffer" don't work ?
The Updatemodes 1,2,4 are all the same. only 3 caused heavy flickering screen.
The zelda and banjo-tooie hack does nothing ?

Offline tofi1106

  • byte
  • *
  • Posts: 12
    • View Profile
Re: Beta Testing Has Begun!
« Reply #116 on: January 21, 2012, 12:04:03 AM »
Yep! I've tried in my optimus p500 cyanogenmod 7.2 overclocked to 729mhz And in a optimus p350 rom stock froyo 2.2.2 V10A TELCEL MEXICO overclocked to 768mhz and occurs the same issue on both devices

Could you run a couple check for me (to maybe zero in on the problem a little closer).

1) Try with Auto Frameskip enabled and Max Frameskip set at 2 (if that's not already the setting you have it on)
2) Try with Auto Frameskip disabled and Max Frameskip set at 0
3) Try with gles2rice instead of gles2n64 to see if it freezes at the same place



sorry but, I was not be able to reply this, I've had a heavy day... well... here are the results:

1) Try with Auto Frameskip enabled and Max Frameskip set at 2 (if that's not already the setting you have it on)
-------This is default configuration, anyway I've put this configuration and everything is ok, it never freezes-----

2) Try with Auto Frameskip disabled and Max Frameskip set at 0
-------Here isn't problem too, everything is perfect except is too slow (obviously), but screen never freezes------

3) Try with gles2rice instead of gles2n64 to see if it freezes at the same place
--Emulation with this plugin is extremely slow, and it have a lot of graphical issues, however, screen never freezes--

Offline GhostlySnow

  • bit
  • Posts: 1
    • View Profile
Re: Beta Testing Has Begun!
« Reply #117 on: January 21, 2012, 12:05:38 AM »
I had to register to say i have had a great experience with this emulator. There are some missing textures on super smash brothers, but i am sure that i could mess around with the settings to work correctly. I set up a six-axis through Bluetooth and it was a very nostalgic experience.
Device: Motorola Droid 2 Global
CPU: TI OMAP 3640, 1.2 GHz (single core, ARM Cortex-A8)
GPU: PowerVR SGX530, 200MHz
RAM: 512 MB
Resolution: 480 x 854
Rom: Galnet MIUI 2.3.7

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #118 on: January 21, 2012, 05:11:11 AM »

1) Try with Auto Frameskip enabled and Max Frameskip set at 2 (if that's not already the setting you have it on)
-------This is default configuration, anyway I've put this configuration and everything is ok, it never freezes-----

2) Try with Auto Frameskip disabled and Max Frameskip set at 0
-------Here isn't problem too, everything is perfect except is too slow (obviously), but screen never freezes------

3) Try with gles2rice instead of gles2n64 to see if it freezes at the same place
--Emulation with this plugin is extremely slow, and it have a lot of graphical issues, however, screen never freezes--

Thanks.  So the problem is specifically gles2n64 when Auto Frameskip is disabled and Max frameskip is greater than zero, correct?
« Last Edit: January 21, 2012, 05:12:49 AM by Paul »
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline FilipIlic

  • bit
  • Posts: 1
    • View Profile
Re: Beta Testing Has Begun!
« Reply #119 on: January 21, 2012, 09:20:45 AM »
Really love your work :) But theres is one thing im kinda missing. Screen orientation. That would make it perfect. Tt runs quite nice. Having  a little problem with the fps, but going to overclock my phone to 1 ghz now and see. :)