Author Topic: Beta Testing Has Begun!  (Read 959250 times)

Offline dshugox

  • bit
  • Posts: 8
  • hiiiiii like the n64
    • View Profile
Re: Beta Testing Has Begun!
« Reply #210 on: February 18, 2012, 08:53:00 AM »
los juegos estan super lentos en mi galaxy ace tube q volver a la 1.6 que es mas rapida
Samsung Galaxy Ace
Operating system stock Android 2.3.6 Gingerbread
CPU   800 MHz Qualcomm MSM7227-1 Turbo, ARMv6
GPU   Adreno 200 GPU
ram   278mb
Data inputs   Multi-touch, capacitive touchscreen
Accelerometer
Display TFT LCD, 3.5 in (89 mm) diagonal.320?480 px HVGA

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #211 on: February 18, 2012, 09:11:05 AM »
Unfortunately, more people experienced the app to be slower when the components without assembly are built in ARM mode instead of THUMB mode.  It seems there isn't a "cookie-cutter" approach to this.  I'll just keep building in THUMB mode, and if it runs better in ARM mode for some devices, then the source code is available and can be rebuilt in ARM mode instead.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline dshugox

  • bit
  • Posts: 8
  • hiiiiii like the n64
    • View Profile
Re: Beta Testing Has Begun!
« Reply #212 on: February 18, 2012, 09:41:37 AM »
cual es la mejor configuracion paul

para el emulador
Samsung Galaxy Ace
Operating system stock Android 2.3.6 Gingerbread
CPU   800 MHz Qualcomm MSM7227-1 Turbo, ARMv6
GPU   Adreno 200 GPU
ram   278mb
Data inputs   Multi-touch, capacitive touchscreen
Accelerometer
Display TFT LCD, 3.5 in (89 mm) diagonal.320?480 px HVGA

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Brock

  • byte
  • *
  • Posts: 27
    • View Profile
Re: Beta Testing Has Begun!
« Reply #214 on: February 18, 2012, 07:08:45 PM »
Hey Paul,
I'm still having the problem with the slow down after recent updates. I'm using 1.7. I was getting 11-13FPS when I was on 1.5 I believe now it hovers around 8-9FPS after the 1.6 update, the 1.7 update didn't seem to help.
Device: Samsung Galaxy S2
CPU: 1.5 GHz Dual Core  Snapdragon S3
RAM: 1GB
Resolution: 800 x 480
Rom: 4.1.2 Jelly Bean Stock

Device: Mach Speed Trio Stealth G2
CPU: 1.5 GHz Dual Core ARM Cortex-A9
RAM: 1GB DDR3
Resolution: 800x480
Rom: 4.0.4 ICS Stock

Device: Mach Speed Trio
CPU: 1.2 GHz Boxchip A13
RAM: 512MB DDR3
Resolution: 480x272
Rom: 4.0.4 ICS Stock

Offline ghshan

  • bit
  • Posts: 9
    • View Profile
Re: Beta Testing Has Begun!
« Reply #215 on: February 18, 2012, 07:24:13 PM »
Hey Paul there's no video for rayman 2
Device: Xperia Play
Android Version: 2.3.4

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #216 on: February 18, 2012, 08:34:10 PM »
@Brock, Try the Xperia Play branch (v1.7.2) and see if it runs better.  I can't really go back to the old gles2n64 code in the main branch, because it causes games like Zelda to crash on Tegra 2 devices and on the Yinlips Console.  I'll probably just have to find other places to optimize.  Maybe once Rice is running well enough to be set as the default video plug-in, I can go back to the old code.

@ghshan, Rayman 2 has a very similar problem to the one that Majora's Mask has (only it happens immediately), where the emulation continues with audio playing, but video and input are frozen.  Hopefully when I fix Majora's Mask, it will fix this one too.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Brock

  • byte
  • *
  • Posts: 27
    • View Profile
Re: Beta Testing Has Begun!
« Reply #217 on: February 18, 2012, 08:57:30 PM »
@Brock, Try the Xperia Play branch (v1.7.2) and see if it runs better.  I can't really go back to the old gles2n64 code in the main branch, because it causes games like Zelda to crash on Tegra 2 devices and on the Yinlips Console.  I'll probably just have to find other places to optimize.  Maybe once Rice is running well enough to be set as the default video plug-in, I can go back to the old code.

I do see a small increase in FPS.
I did a little testing here's what I found.
I get 5-6 FPS while moving in SM64 when I switched to the Xperia Play version it's 6-7 FPS with occasional 8 FPS spikes. I noticed that the Xperia Play version produces better performance in most areas of the game but it's very erratic with weird spikes and dips in the framerate but I'm guessing because it's optimized for the Xperia Play.
Device: Samsung Galaxy S2
CPU: 1.5 GHz Dual Core  Snapdragon S3
RAM: 1GB
Resolution: 800 x 480
Rom: 4.1.2 Jelly Bean Stock

Device: Mach Speed Trio Stealth G2
CPU: 1.5 GHz Dual Core ARM Cortex-A9
RAM: 1GB DDR3
Resolution: 800x480
Rom: 4.0.4 ICS Stock

Device: Mach Speed Trio
CPU: 1.2 GHz Boxchip A13
RAM: 512MB DDR3
Resolution: 480x272
Rom: 4.0.4 ICS Stock

Offline ghshan

  • bit
  • Posts: 9
    • View Profile
Re: Beta Testing Has Begun!
« Reply #218 on: February 18, 2012, 08:59:28 PM »
@Brock, Try the Xperia Play branch (v1.7.2) and see if it runs better.  I can't really go back to the old gles2n64 code in the main branch, because it causes games like Zelda to crash on Tegra 2 devices and on the Yinlips Console.  I'll probably just have to find other places to optimize.  Maybe once Rice is running well enough to be set as the default video plug-in, I can go back to the old code.

@ghshan, Rayman 2 has a very similar problem to the one that Majora's Mask has (only it happens immediately), where the emulation continues with audio playing, but video and input are frozen.  Hopefully when I fix Majora's Mask, it will fix this one too.
good luck with that. Mario tennis and paper Mario have similar problems. The video is rather
glitchey.

P.S if you find the time could you make a mobile version of your site?
« Last Edit: February 18, 2012, 09:10:47 PM by ghshan »
Device: Xperia Play
Android Version: 2.3.4

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #219 on: February 18, 2012, 09:22:58 PM »
You can click the WAP2 link at the bottom of the page if you're having trouble navigating the website on your phone.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline leo_fre

  • bit
  • Posts: 3
    • View Profile
Re: Beta Testing Has Begun!
« Reply #220 on: February 19, 2012, 03:14:57 PM »
Hi Paul!

I tested version 1.7 and start your emulator on my Optimus One P500, but slow, even at 806 MHz have problems with sound cutting and have arranged the unemployed in the actions of the buttons A and B in a way that not noticed.

I want to give an opinion and I hope you'll be pleasantly: Many people who use your emulator will be those with mid-range devices and low and ARMv6 processors so my suggestion is:

You could improve your emulator so that the speed of emulation is regular at least 740 or 720 MHz in my Optimus One?

I know I can be asking a lot but newbielink:http://www.chileandroid.com [nonactive] forum are thankful that you have created this emulator, since the bulk of smartphone users use this and other mid-range, and everyone would be grateful that your emulator is released pulling at a good speed.

I hope you answer me. Thank you  ;D.

PS: I tried your recommendations for better emulation and did not fix the problem much I can say that makes it worse.
« Last Edit: February 19, 2012, 08:41:22 PM by leo_fre »

Offline ghshan

  • bit
  • Posts: 9
    • View Profile
Re: Beta Testing Has Begun!
« Reply #221 on: February 24, 2012, 09:19:52 PM »
Hey Paul I'm abit weirded out here. I have the xperia play version of your app but my phone says I have purchased your other app. What can you tell me about this.(I don't have a credit card just so u know)
« Last Edit: February 24, 2012, 09:24:21 PM by ghshan »
Device: Xperia Play
Android Version: 2.3.4

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #222 on: February 24, 2012, 09:28:12 PM »
The system google has set up is a bit finicky at times.  I wouldn't be too worried about it (it is probably just confused because the apps I have posted here use the same digital signature as the ones on the Market).
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline ghshan

  • bit
  • Posts: 9
    • View Profile
Re: Beta Testing Has Begun!
« Reply #223 on: February 25, 2012, 06:29:36 PM »
No audio in 007- the world is not enough
Device: Xperia Play
Android Version: 2.3.4

Offline Vincentmrl

  • Cyan Team
  • long
  • *
  • Posts: 121
    • View Profile
Re: Beta Testing Has Begun!
« Reply #224 on: February 26, 2012, 05:35:39 AM »
Hey Paul, Remember me?
I have a lot problems with the emu, aka it's extremely laggy, and i saw the fact that you changed the gles2n64 code, i have an idea: can't you put the old and new gles plugins in the plugin selector? so who can would select the old and faster version! (and i could finally play loz somewhere, searching so bad for oot (i have a n64)). Mario was going at 50-55 fps in the old version with audio, now it's extremely lagging with no audio and any frameskip, please solve this :(, i'll wait for an answer ;)
also: will you make something like a touch controls position changer? would be nice for people that can't use buttons and are forced to touchscreen (i hate that z button's position, i'm using volume key for it anyway)
Device: Lg Optimus One
CPU: 600 Mhz ARMv6 (Overclocked to 748Mhz ondemand governor)
GPU: Qualcomm Adreno 200
RAM: 512 MB
Resolution: 320 x 480
Rom: Unofficial Cyanogenmod 9