Author Topic: Beta Testing Has Begun!  (Read 960613 times)

Offline androidian

  • byte
  • *
  • Posts: 14
    • View Profile
Re: Beta Testing Has Begun!
« Reply #225 on: February 26, 2012, 06:06:36 AM »
Hey Paul, Remember me?
I have a lot problems with the emu, aka it's extremely laggy, and i saw the fact that you changed the gles2n64 code, i have an idea: can't you put the old and new gles plugins in the plugin selector? so who can would select the old and faster version! (and i could finally play loz somewhere, searching so bad for oot (i have a n64)). Mario was going at 50-55 fps in the old version with audio, now it's extremely lagging with no audio and any frameskip, please solve this :(, i'll wait for an answer ;)
also: will you make something like a touch controls position changer? would be nice for people that can't use buttons and are forced to touchscreen (i hate that z button's position, i'm using volume key for it anyway)
50-55fps on 600mhz proccesor?Is this true how to do that?

Offline Tom.K

  • Green Team
  • long
  • *
  • Posts: 130
    • View Profile
Re: Beta Testing Has Begun!
« Reply #226 on: February 26, 2012, 02:09:49 PM »
You're kidding me... 50-55 fps!? We have almost same specs and maximum FPS I get is about 20...

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #227 on: February 26, 2012, 04:15:01 PM »
I take it that was just an exageration to make a point that it used to run faster.  Mario 64 runs 30 FPS at full speed, even if the hardware is capable of running it faster.  If it were running much faster than that, it would indicate a problem in the code.
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline Brock

  • byte
  • *
  • Posts: 27
    • View Profile
Re: Beta Testing Has Begun!
« Reply #228 on: February 26, 2012, 04:21:50 PM »
Hey Paul, Remember me?
I have a lot problems with the emu, aka it's extremely laggy, and i saw the fact that you changed the gles2n64 code, i have an idea: can't you put the old and new gles plugins in the plugin selector? so who can would select the old and faster version! (and i could finally play loz somewhere, searching so bad for oot (i have a n64)). Mario was going at 50-55 fps in the old version with audio, now it's extremely lagging with no audio and any frameskip, please solve this :(, i'll wait for an answer ;)
also: will you make something like a touch controls position changer? would be nice for people that can't use buttons and are forced to touchscreen (i hate that z button's position, i'm using volume key for it anyway)
50-55fps on 600mhz proccesor?Is this true how to do that?

Were you really getting 50-55FPS? I have an 600MHz ARMv6 processor overclocked to 729MHz and I'm not getting playable speeds even with the latest build. I wasn't around for the alpha builds so I can't really go back and test with the old plugin. I trust Paul's decision when he updates plugins and adds new features so I'm thinking 50-55FPS is very unlikely on a 600MHz processor. I think Paul is right.
Device: Samsung Galaxy S2
CPU: 1.5 GHz Dual Core  Snapdragon S3
RAM: 1GB
Resolution: 800 x 480
Rom: 4.1.2 Jelly Bean Stock

Device: Mach Speed Trio Stealth G2
CPU: 1.5 GHz Dual Core ARM Cortex-A9
RAM: 1GB DDR3
Resolution: 800x480
Rom: 4.0.4 ICS Stock

Device: Mach Speed Trio
CPU: 1.2 GHz Boxchip A13
RAM: 512MB DDR3
Resolution: 480x272
Rom: 4.0.4 ICS Stock

Offline Vincentmrl

  • Cyan Team
  • long
  • *
  • Posts: 121
    • View Profile
Re: Beta Testing Has Begun!
« Reply #229 on: February 27, 2012, 12:27:27 AM »
http://www.youtube.com/watch?v=mIEhRlM1a_A&feature=youtube_gdata_player in fact in my old video castle could be compared to my n64 even if it had some slowdowns in the levels obviously, if at that time i had root, a frameskip 1 would be perfect, anyway i'm using the xperia version which made oot playable
Device: Lg Optimus One
CPU: 600 Mhz ARMv6 (Overclocked to 748Mhz ondemand governor)
GPU: Qualcomm Adreno 200
RAM: 512 MB
Resolution: 320 x 480
Rom: Unofficial Cyanogenmod 9

Offline dshugox

  • bit
  • Posts: 8
  • hiiiiii like the n64
    • View Profile
Re: Beta Testing Has Begun!
« Reply #230 on: February 27, 2012, 09:25:01 AM »
hi paul

my question is

para q sirve esto

Debug Build  (26 Feb 2012)

es un mejora algo?
Samsung Galaxy Ace
Operating system stock Android 2.3.6 Gingerbread
CPU   800 MHz Qualcomm MSM7227-1 Turbo, ARMv6
GPU   Adreno 200 GPU
ram   278mb
Data inputs   Multi-touch, capacitive touchscreen
Accelerometer
Display TFT LCD, 3.5 in (89 mm) diagonal.320?480 px HVGA

Offline dshugox

  • bit
  • Posts: 8
  • hiiiiii like the n64
    • View Profile
Re: Beta Testing Has Begun!
« Reply #231 on: February 27, 2012, 09:28:54 AM »
hi paul

my question is

para que sirve esto

Debug Build  (26 Feb 2012)

es un mejora algo?
Samsung Galaxy Ace
Operating system stock Android 2.3.6 Gingerbread
CPU   800 MHz Qualcomm MSM7227-1 Turbo, ARMv6
GPU   Adreno 200 GPU
ram   278mb
Data inputs   Multi-touch, capacitive touchscreen
Accelerometer
Display TFT LCD, 3.5 in (89 mm) diagonal.320?480 px HVGA

Offline Tom.K

  • Green Team
  • long
  • *
  • Posts: 130
    • View Profile
Re: Beta Testing Has Begun!
« Reply #232 on: February 27, 2012, 02:26:43 PM »
Hey Paul, Remember me?
I have a lot problems with the emu, aka it's extremely laggy, and i saw the fact that you changed the gles2n64 code, i have an idea: can't you put the old and new gles plugins in the plugin selector? so who can would select the old and faster version! (and i could finally play loz somewhere, searching so bad for oot (i have a n64)). Mario was going at 50-55 fps in the old version with audio, now it's extremely lagging with no audio and any frameskip, please solve this :(, i'll wait for an answer ;)
also: will you make something like a touch controls position changer? would be nice for people that can't use buttons and are forced to touchscreen (i hate that z button's position, i'm using volume key for it anyway)
50-55fps on 600mhz proccesor?Is this true how to do that?

Were you really getting 50-55FPS? I have an 600MHz ARMv6 processor overclocked to 729MHz and I'm not getting playable speeds even with the latest build. I wasn't around for the alpha builds so I can't really go back and test with the old plugin. I trust Paul's decision when he updates plugins and adds new features so I'm thinking 50-55FPS is very unlikely on a 600MHz processor. I think Paul is right.

Some other games in general have 60 FPS, and I mostly like it when it's more smooth, and I still think that it should be possible to be that fast, at least make it configurable. Still, on low FPS... low sound quality, it's worse quality no matter what.

Offline MattyGlen

  • byte
  • *
  • Posts: 44
    • View Profile
Re: Beta Testing Has Begun!
« Reply #233 on: February 27, 2012, 06:31:11 PM »

Some other games in general have 60 FPS, and I mostly like it when it's more smooth, and I still think that it should be possible to be that fast, at least make it configurable. Still, on low FPS... low sound quality, it's worse quality no matter what.

Please correct me if i'm wrong but there is no need for higher then 30FPS (on any region), in fact anything over 30FPS will not make games appear any more smoother graphically.
Device: Xperia Play R800i
Resolution: 480 x 854
CPU: 1.8GHz (OC) Qualcomm Snapdragon MSM8x55 chipset
GPU: Adreno 205 245 MHz
RAM: 512 MB
Rom: Verizon 4.0.2.A.0.62 Gingerbread 2.3.4 rooted

Offline Tsudeily

  • bit
  • Posts: 9
    • View Profile
Re: Beta Testing Has Begun!
« Reply #234 on: February 27, 2012, 06:33:45 PM »
I have noticed that to be true as well.

Offline shuy3n

  • long
  • ***
  • Posts: 111
    • View Profile
Re: Beta Testing Has Begun!
« Reply #235 on: February 27, 2012, 08:15:38 PM »

Offline Tom.K

  • Green Team
  • long
  • *
  • Posts: 130
    • View Profile
Re: Beta Testing Has Begun!
« Reply #236 on: February 28, 2012, 04:34:56 AM »

Some other games in general have 60 FPS, and I mostly like it when it's more smooth, and I still think that it should be possible to be that fast, at least make it configurable. Still, on low FPS... low sound quality, it's worse quality no matter what.

Please correct me if i'm wrong but there is no need for higher then 30FPS (on any region), in fact anything over 30FPS will not make games appear any more smoother graphically.

For me it's wrong still... 30 fps for me just isn't smooth for me... Maybe it's something else, never mind.

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #237 on: February 28, 2012, 10:05:46 PM »
Here is the latest build, with hires texture (gles2rice) and multi-controller interfaces.  There are still a few small odds and ends I want to add in tomorrow before I post the official update.  Please let me know if you notice any bugs, so I can take care of those tomorrow evening as well:

Update, RC1
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted

Offline scorpio16v

  • long
  • ***
  • Posts: 203
    • View Profile
Re: Beta Testing Has Begun!
« Reply #238 on: February 28, 2012, 11:37:23 PM »
The import texture pack option isn't complete, right ?
Because I can only browse in the folder tree of the pack. It's impossible to select the main folder.

I can't select the option to enable hires packs.
After resetting the settings and restore data, the enable pack option is preselected, but impossible to unselect.
To select a pack is still impossible.
« Last Edit: February 29, 2012, 12:14:38 AM by scorpio16v »

Offline Paul

  • Administrator
  • double
  • *****
  • Posts: 3499
  • Developer
    • View Profile
    • PaulsCode.Com
Re: Beta Testing Has Begun!
« Reply #239 on: February 29, 2012, 04:45:07 AM »
The texture pack must be in .zip format currently (since I haven't written a folder-select capability into the file browser yet).  I fixed the problem with the Enable HiRes Textures option not responding (small typo in the code).

Update, RC2
Device: Samsung Galaxy Nexus i515
CPU: TI OMAP4460, 1.2 GHz (dual core, ARM Cortex-A9)
GPU: PowerVR SGX540, 307 MHz
RAM: 1 GB
Resolution: 720 x 1280
Rom: omni-4.4.4-20141014-toro-FML KitKat 4.4.4, rooted

Device: Eee PC 1015PEM
CPU: Intel Atom N550, 1.5 GHz (dual core, x86)
GPU: Intel GMA 3150, 200 MHz (dual core)
RAM: 2GB
Resolution: 1024 x 600
Rom: android-x86-4.3-20130725 Jelly Bean 4.3, rooted